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1 Small Utilities
About Small Utilities

blur2d

The blur2d utility applies a 2D motion blur on the input image based on 
saved motion vector information. In Maya, motion vectors are saved with 
the image during rendering when Keep Motion Vectors is turned on in the 
Motion Blur section of the Render Global Settings window. 

To use blur2d

From a IRIX or Linux shell, Terminal window, or command prompt, type:

blur2d [-h] [-l blurLength] [-s blurSharpness] 
[-m smoothValue] [-n start end step] [-f inputFileName] 
[-r smoothColor]

Option Description

-h Displays the help file.

-l <float> Blur length. The value must be greater than 0. The 
default value is 1.

-s <float> Blur sharpness. The value must be greater than 0. The 
default value is 1.

-m <int> Smooth value. The value must be greater than or equal 
to 0. The default value is 2.

-r <boolean> Whether to smooth color (1) or not (0). The default 
setting is 0.

-n Animation start frame, end frame, and step.

-c <string> Name of the image file, for example, picNoBlur.iff 

-v <string> Name of the file containing motion vectors (cannot be 
used with -f).

-f <string> Name of the containing images and vectors (cannot be 
used with -v).

-p <int> Frame padding to the maximum number of leading 
zeros. The default is none.
Rendering Utilities

7



1 | Small Utilities
About > blur2d
Examples

blur2d -f sphere.iff

The blurred image is saved as sphere_blur.iff.

blur2d -l 4 -f sphere.iff

The image is blurred with a blur length of 4 and saved as 
sphere_blur.iff.

blur2d -n 1 10 1 -f sphere.iff

The input image sequence being sphere.iff.1 ... sphere.iff.10, the 
output sequence would be sphere_blur.iff.1 ... 
sphere_blur.iff.10.

To blur an animation sequence, the sequence files have to be named as 
name.ext.# or name.#.

The command to blur the name.ext.# sequence is:

blur2d -n start end by -f name.ext

The command to blur the name.# sequence is:

The following example uses the motion path of one image and applies it 
to another. This is useful when you are rendering a very large file (which 
you want to speed up by not rendering motion blur). This example does a 
second, fast render (no lights or textures, low anti-aliasing) at the same 
resolution and with motion vectors on, and uses this to apply blur to the 
very large render. 

blur2d -n 1 500 1 -l 2 -f ImageBeautry -v imageVector 

imageBeauty is the high quality render and imageVector is the low quality 
render with motion vectors.

blur2d -n start end by -f name

-o memLimit Maximum allowed memory usage in MB.

Note: When using the -c and -v options, the image files must be 
the same size or the results may be unpredictable.

Option Description
Rendering Utilities
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About > FieldAssembler
FieldAssembler

The FieldAssembler utility interlaces rendered field images. Fields are 
images made up of alternate lines as displayed on NTSC devices.

Each field image, contains only half of a full frame, and each field is stored 
in a separate file. Rendering images in this manner can be helpful when 
designing animations that will be played back on NTSC devices. 
However, to view these images on a computer screen, or to transfer them 
to certain other computer programs, such as compositing software, you 
need to reassemble them into full images. When this happens, you have 
half as many files, and each file has twice as much data.

To open FieldAssembler

Do either of the following:

• From a command prompt, type fieldassembler.

• In C:\Program Files\Alias\Maya6.5\bin, double-click 
FieldAssembler.exe.

For information on FieldAssembler, select Help > Help from within the 
FieldAssembler window.

from100to97

The from100to97.exe program is an Alias Wire file translator. It will 
convert Studio 10 wire files to Studio 9.7 wire files.

interlace

The interlace utility is used to interlace field rendered images. Field 
rendered images are images in a sequence of images designed for video 
playback on NTSC devices. Each field, or image, contains only 1/2 of a 
full frame, and each field is stored in a separate file. Rendering images in 

Note: FieldAssembler is only available for Windows. Use 
interlace for IRIX or Linux. Use a non-linear editor or 
compositing application for Mac OS X. See ”interlace” on 
page 9 for details.

Note: interlace is available for Mac OS X, IRIX and Linux. Use 
FieldAssembler for Windows. See ”FieldAssembler” on 
page 9 for details.
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About > filePaste
this manner can be helpful when designing animations that will be played 
back on NTSC devices. However, to view these images on a computer 
screen, or to transfer them to certain other computer programs, you need 
to reassemble them into full images. When this happens, you end up with 
half as many files, and each file has twice as much data.

To use interlace

From a IRIX or Linux shell, type:

interlace [-a # # #] [-d] [-e #] [-r] [-t str] base_image_name

filePaste

The filePaste utility takes a list of image files and pastes the image files 
together in horizontal pieces to form a larger image.

This is very useful when rendering a single large resolution image, 
wherein a group of machines is used for computing resources. With 
render region capabilities in Maya’s renderer, each machine resource can 
render a portion of the image. At the end of the renderings, use filePaste 
to concatenate the rendered images.

To use filePaste

From a IRIX and Linux shell, type:

filePaste <inputImage1> <inputImage2> <inputImage...> <outputImage>

Option Description

-a [# # #] Specifies an animation to be interlaced the three numbers 
are start frame, end frame and by frame. The start end and 
by frame must be integers currently.

-d Specifies the even field to be the first field; otherwise, the 
odd field is the first field. This option should agree with the 
field option in Render Global Settings windows.

-e Specifies the padding length of the extensions.

-r Deletes the original field images.

-t Specifies the file extension trailer (for example, sgi).

-u Unlaces frames into fields.

-help Displays the help file.
Rendering Utilities
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fileStats

The fileStats utility takes a list of image files and outputs resolution 
information in terms of: 

• header resolution: this is the resolution as specified in the header of 
the image file.

• actual resolution: this is the actual resolution of the image file. This is 
only different from the header resolution if the image is incomplete.

The actual resolution is a good mechanism for render farms to detect if the 
rendering actually completed this frame (sometimes the uncompleted file 
is due to disk space shortage situations, or NFS problems, and the 
renderer may not be able to know about the problems to tell the render 
farm).

To use fileStats

From a IRIX or Linux shell, type:

fileStats <image1> <image2> <image...>

imconvert (Image Magick)

The imconvert utility can process images, convert images from one 
format to another, and join images. For a list of options, type 
imconvert -h in a shell window.

imgcvt

The imgcvt utility converts images or sequences of images from one 
image format to another. 

In a shell window, enter imgcvt followed by the name of the image you 
want to convert. The input and output image formats are usually 
determined by the filename extension or image content. However, when 
the input or output image has no extension, or cannot be identified, the -f 
and -t options can be used to indicate the desired formats. You can use 
the following options:

imgcvt <options> input_image output_image

Example 1

imgcvt -f sgi -t tiff input_image output_image

This command converts the image named input_image that is in the 
Silicon Graphics format to the TIFF format and saves the image out to a 
different name, output_image. 
Rendering Utilities
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About > imgcvt
Example 2

imgcvt -f tiff -t iff input_image output_image

This command converts an tiff image to the IFF file format.

Options

Command line options Description

-f input_image_extension Identifies the specific image format that you are converting 
from. For example:

-f sgi 

This indicates that only files matching the Silicon Graphics 
image format are accepted as input.

-t output_image_extension Identifies the specific image format that you are converting 
to. For example:

-t tiff

This indicates that files will be converted to the TIFF image 
format only. For the list of possible extensions, see “Image 
extensions”. 

-n start end step Is the start, end and step of an input image sequence (only 
whole numbers are accepted). 

-N start end step Is the start, end and step of an output image sequence (only 
whole numbers are accepted). 

-r range In an input image sequence, selects the range of images to 
be converted from. For example:

imgcvt -r 1-5 ...

imgcvt -r 1-5x2 ...

imgcvt -r 1-5,10-20x2,50 ...

A sequence specifier is a list of single frames or ranges 
separated by a comma or a slash. For each range, an 
optional step can be specified after a x.

Sequences can be reversed and offsets can be added to the 
input or output frame number:

imgcvt -r 100-1 -R 1-100 in.#.rgb out.#.rla

imgcvt -r 1-100 in.#.rgb out.#+100.rla

These are individual sequentially numbered image files.
Rendering Utilities
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When you are working on a sequence of images, the # and @ symbols are 
used to reference the current frame number. The hash (#) indicates a four-
digit padded number, whereas @ symbol indicates a non-padded number. 
The following converts a sequence of 100 frames:

imgcvt -n 1 100 1 image_in.iff.@ image_out.#.rla

For more precise control of the frame number format, use either multiple 
@ symbols to set a specific padding or use the standard printf(3S) 
notation:

imgcvt -n 1 100 1 image_in.@@@.rgb image_out.#.rla
imgcvt -n 1 100 1 image_in.%03d.rgb image_out.#.rla
imgcvt -n 1 100 1 image_in.%.2f.rgb image_out.#.rla

Image extensions

Use the following extensions to convert images from one image format to 
another. In the -f option, you specify the extension of the image format 
you are converting from. In the -t option, you specify the extension of the 
image format you are converting to.

-R range In an output image sequence, selects the range of images to 
be converted to. 

-h Provides a brief description of each option.

-s Silent mode.

-v Verbose mode.

-V pal/ntsc Video mode for yuv files.

-C compress TIFF compression types: LZW (this is the default) or NONE.

-q N JPEG quality (0..100; 75 default).

-m Explore map format.

Command line options Description

Image format Extension

Abekas NTSC or PAL .yuv

Alias .als
Rendering Utilities
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Explore

GIF .gif

JPEG .jpg

Kodak Cineon .cin

Lucas Film .lff

Pixibox PXB and SCN .pxb or .scn

PPM raw/ascii .ppm

Prisms .pri

Quantel .qtl

SGI .rgb, .sgi or .bw

Softimage .pic

Targa RGB/BW .tga

TIFF 6.0 .tif or .tiff

Vista .vst

Wavefront RLA .rla

Image format Extension
Rendering Utilities
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2 Dispatcher
About Dispatcher

Overview of Dispatcher 

The dispatcher utility is used to distribute rendering and post-production 
jobs across a network of computers.

The Dispatcher distributes the execution of rendering and post-production 
jobs over the network. Important features include:

• handling job priorities

• providing you with overall job control from a central menu

• notifying you when any job is completed and performing further 
actions depending on how you choose the configuration settings 

• distributing jobs on any number of workstation processors

Since the Dispatcher executes frames in parallel with other frames 
(multiplying the execution rate), it can complete rendering jobs much 
quicker than a traditional render command line that executes all the 
frames on a single machine. 

The Dispatcher can run in several environments—Maya, Studio, and IPR. 

Who uses Dispatcher?

Two kinds of professionals use the Dispatcher: end users and network 
administrators. 

End users need to understand pools, how to add a machine to a pool, and 
how to submit jobs to the Dispatcher. See ”For end users” on page 35. 
(Most end users will not be concerned with the installation and 
configuration settings that are described in ”For network administrators” 
on page 16.)

Network administrators are responsible for installing and configuring the 
Dispatcher. See ”For network administrators” on page 16.

Note: Dispatcher is only available for IRIX. 
Rendering Utilities
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For network administrators

Before you install

This is intended for network administrators who install the Dispatcher 
and assist end users. Before end users can start the Dispatcher, the 
program must be installed and running on the machine(s).

The Dispatcher starts a master job known as the spooler on one machine. 
This is the central controlling job that decides where to allocate the jobs 
you submit. Each machine that will be able to execute submitted jobs must 
be running a client—a job that sleeps most of the time and periodically 
checks the status of the machine and any job it may be running.

The Dispatcher is composed of three cooperating programs: 

• dispatcherSpool resides on the machine that you choose to act as the 
spooler or server. 

• dispatcherClient resides on each machine used to run jobs you 
submit.

• dispatcher is the program that end users interact with.

Each time you start the Dispatcher, the program looks for dispatcherSpool 
and dispatcherClient. These two components become active upon 
machine restart and keep track of dispatched jobs, the machines being 
used, and other details. If either of these two components is not 
monitoring the dispatching activity, end users may have trouble 
dispatching jobs. 
 

Set up before installing the Dispatcher

As part of setting up the Dispatcher, here are some things you need to 
look at before end users run the program.

Include the executables in the $PATH

Make sure the path of the executables, such as Maya, is in the $PATH of 
each ordinary Dispatcher user. Otherwise, you need to modify the .cshrc 
file of each Dispatcher user according to the product she or he plans to 
use.

Note: The MAYA_PROJECT environment variable must be set. 
The MAYA_PROJECT environment variable specifies where 
to find the Maya data files. This environment variable can 
be set either in your .cshrc file or in the scripts used for 
starting rendering jobs in Maya.
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For example, in the Maya environment, this means the Dispatcher can 
locate the Render command when users type Render without giving the 
full path of the executable in the Submit Job window. For other 
environments, also make sure that the rendering commands are in the 
$PATH of each end user’s machine.

Test access between networked machines

Make sure any disks Dispatcher end users are likely to write to or read 
from over the network can be accessed. This means NFS must be installed 
on your machine. You can find out whether NFS is installed by examining 
the output from the following command.

versions | grep nfs

The following shows typical output:

Product 
Environment

Add this to the .cshrc of every user

Maya 5.0 set path = (/usr/aw/maya5.0/bin $path)

Studio set path = (/usr/aw/alias9.5/bin $path)

IPR set path = (/usr/aw/EXP4.3.3/bin $path)

Installed Subsystem Date Description

I nfs 08/28/97 Network File System, 
6.3

I nfs.man 08/28/97 NFS Documentation

I nfs.man.nfs 08/28/97 NFS Support Manual 
Pages

I nfs.man.relnotes 08/28/97 NFS Release Notes

I nfs.sw 08/28/97 NFS Software

I nfs.sw.nfs 08/28/97 NFS Support

I nfs.sw.nis 08/28/97 NIS (formerly Yellow 
Pages) Support

I nfs3 08/28/97 Network File System 
Version 3, 6.3
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To find out whether NFS is actually running on a machine, type the 
following command:

chkconfig

By examining the output from this command, you will see whether nfs is 
set to on or off.

To be sure NFS is active, type the following command:

ps  -aef | grep nfsd

This is typical output from this command:

Example—setting up for dispatching

The following list of network machines are connected by Ethernet:

• machine1

• machine2

• machine3

• machine4

On each of these machines, suppose that you create a login named 
myname. The project is stored on the disk shared by all these machines. 
The images rendered on the machines will also be stored on this disk. For 
the Dispatcher to work properly, you need to have the same login 
available on all the machines and set it up as a shared login.

I nfs3.sw 08/28/97 NFS Version 3 Software

I nfs3.sw.nfs3 08/28/97 NFS Version 3 Support

root 180 1 0 Aug 21 ? 0:00 /usr/etc/nfsd 4

root 181 180 0 Aug 21 ? 0:00 /usr/etc/nfsd 4

root 182 180 0 Aug 21 ? 0:00 /usr/etc/nfsd 4

root 183 180 0 Aug 21 ? 0:00 /usr/etc/nfsd 4

myname 887 27388 1 19:07:16 pts/3 0:00 grep nfsd
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Share an account

You must set up each account so that it can be shared on the networked 
machines as opposed to creating a separate account with the same name 
on each machine. You can do this by defining a mount point so that each 
user name is connected to the same mount point on remote machines as 
on the local machine.

To share an account

Assume that the account named myname was set up on machine1 under 
the /usr/people directory. 

On machine1:

1 Log in as root.

2 In the /etc/passwd file, you may find a line such as:

myname:password:userid:group_userid:description:/usr/people/myname:/bin/csh

A typical line in the passwd file resembles the following line.

username:password:userid:group_userid:description:home_directory:/bin/csh

The part /usr/people/myname is local to machine1. Define how this 
location is recognized on the network. For example, you can decide 
that it is recognized by the other machines as 
/mount_machine1/myname.

On all the other machines (machine2, machine3, and 
machine4):

1 Log in as root.

2 Edit the /etc/passwd file and add the following line:

myname:password:userid:group_userid:description:/mount_machine1/myname:/bin/csh

For other machines to recognize the /mount_machine1/myname 
mounting point, you need to do two more steps on machine1.

On machine1:

1 Export the disk so that all machines are allowed to write data to it. For 
more information, ”To export a disk” on page 20.

2 Mount the directory.

In this example, the login was set up under /usr/people, so this 
partition needs to be recognized by the other machines. 

Check the /etc/exports file and make sure the /usr/people (or /
usr) directory is defined. If the entry point is not defined, follow the 
next procedure.
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To define an entry point

1 Edit the /etc/exports file and add the following lines:

/usr/people

/usr/etc/exportfs -a -v

On all other machines

1 Log in as root.

2 Create the mounting point named /mount_machine1:

mkdir /mount_machine1

3 In the /etc/fstab file, add the following lines:

machine1:/usr/people /mount_machine1 nfs rw,bg,soft 

0 0

mount /mount_machine1

You can now log in as myname on all these machines.

Export a disk

The following example shows how to share a disk named DiskA mounted 
on machine1 so the disk can be accessed from the other machines.

To export a disk

1 Log in as root.

2 Edit the file /etc/exports by adding /DiskA to the file. The file /
etc/exports describes the filesystems that are being exported to NFS 
clients. 

3 Enter the following line:

/usr/etc/exportfs -a -v

Exportfs makes a local directory (or file) available for mounting over 
the network by NFS clients. 

4 On each of the other machines (machine2, machine3, and machine4), 
create a directory named /DiskA.

5 In the /etc/fstab file, add the following line:

machine1:/DiskA /DiskA nfs rw,soft,bg 0 0

Each time these machines are rebooted, the /DiskA directory is 
automatically mounted allowing access to the DiskA disk.

6 To see the list of accessible partitions, enter:

/etc/mount -p 
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On machine1, the following line should be displayed:

/dev/dsk/dks1d7s7  /DiskA    efs  raw=/dev/rdsk/

dks1d7s7  0 0

On the other machines, the following line should be displayed:

machine1:/DiskA        /DiskA    nfs  rw,soft,bg  0 

0

In this example, the /IMAGES directory was created on /DiskA for 
storing projects. 

The /DiskA disk has the following permissions:

drwxrwxrwx    9 root     sys          512 Aug  8 

05:55 DiskA/

The /IMAGES directory has the following permissions:

drwxrwxrwx    4 root     sys          512 Aug 10 

02:59 IMAGES

Sign on to different accounts

A security mechanism prevents remote users on the network from 
submitting jobs to machines without being set up to do so. However, 
Dispatcher end users cannot submit a job to the Dispatcher unless they 
can login (rlogin) to the other machines without supplying their 
password. This means that the network administrator must configure the 
machines so that end users don’t have to type their password every time 
they want to dispatch a job to another machine.

To sign on to a different account

1 Edit the file named /etc/hosts.equiv by adding the names of the 
machines that Dispatcher end users need to access. In this example, 
add the following machine names to the contents of this file: 
machine1, machine2, machine3, and machine4.

under 
machine1

under 
machine2

under 
machine3

under 
machine4

machine2 machine1 machine1 machine1

machine3 machine3 machine2 machine2

machine4 machine4 machine4 machine3
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This means the Dispatcher end users can rlogin to these machines 
without having to type a password. A convenient feature of the 
Dispatcher is that users can execute jobs over networked machines 
regardless of the group id they belong to.

2 Copy /etc/hosts.equiv under the home directory of each machine. 
For example, under machine1, enter:

cp /etc/hosts.equiv /usr/users/myname/.rhosts

The owner of the .rhosts file must be the root or the user in whose 
home directory it resides. The contents of an user’s .rhosts file will be 
disregarded if it is owned by another user or if its permissions allow 
anyone who is not the owner to modify the file. Use the chmod 
command to add the proper protection:

chmod go-w .rhosts

Similarly, the file named /etc/hosts.equiv must be owned by and 
writable only by the super-user.

For more details on the .rhosts file, type:

man rhosts 

Set up the Dispatcher: other recommendations

Ensure that:

• the Dispatcher program is shared so that Dispatcher end users can run 
the program.

• the machines Dispatcher end users will need are running.

• the applications (for example Render) that end users are likely to use 
with the Dispatcher can execute jobs on each machine. To do this, log 
onto each machine and enter, for example:

Render myscene.ma

The Render command shown here is valid in Maya, but in other 
environments, you must replace Render with the appropriate 
command for rendering.

If the Render command runs, this means the application and its keys 
are recognized by this machine. If you receive the message Render: 
command not found, look under the /usr/aw/mayax.x/bin directory 
to see whether the program is installed. 

Make sure the path is correct by typing: 

which Render

or, while logged onto the spooler, enter the following lines:

foreach i  ( ‘cat /etc/dispatch.hosts‘ )

echo "--------------------------------"
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echo HOST: $i

rsh $i which Render

end

• the .cshrc of your login lets you submit jobs in batch mode. You can 
test whether the correct path to an application is found by entering, 
for example, for Maya:

rsh machine which Render

Run the installation script

To install the Dispatcher

1 Login as root. 

2 Choose a machine on which you want the spooler to run.

3 Note its host name.

4 Go to the subdirectory that contains the dispatcher_install script.

cd /usr/aw/COM/bin

5 Run the installation script as root on each machine that you wish to 
use as a client by entering:

./dispatcher_install

This script locates the Dispatcher binaries, keeps track of the machine 
you are using as your spooler, and sets up a shell script named 
dispatcher in the /etc/init.d directory to control how the 
Dispatcher is executed. The dot in the command stands for the 
working directory you went to in step 4. It is easier than typing the 
full pathname. 

To find out whether you have already run the dispatcher_install 
script, type the following command:

chkconfig

If the dispatcherClient is not set to on in the list of options that you 
can set, run dispatcher_install on that machine.

6 Follow the instructions on the screen (the script shown as follows 
includes explanations of what each section of the script tells the 
Dispatcher to do). 

7 If the automount feature is on, specify the default path /usr/aw/COM/
bin. Always express the path relative to the symbolic link of the 
mount point. For instance, if the directory /usr/aw is automounted 
and is a symbolic link to /tmp_mnt/usr/aw, give the path /usr/aw 
rather than /tmp_mnt/usr/aw.
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8 Answer Yes whenever possible, especially to the email questions, 
because this makes it easier to troubleshoot any configuration 
problems in your scripts or the scripts of end users.

9 When the installation is complete, enter the following to start the 
Dispatcher:

/etc/init.d/dispatcher start 

An alternative to this command is to shut down and restart your 
machine.

10 As root, log into each client machine (you can also do an rlogin to each 
client machine), then enter:

./dispatcher_install

and answer the questions presented on the screen. Each time you 
install a spooler, you must re-install all the clients. Previously installed 
clients cannot be used.

Example installation script

When you install the Dispatcher, the script prompts you for information, 
as shown in this section. The replies display in bold on your machine. Go 
to the proper directory as described earlier (step 4). 

Dispatcher prompts (installation 
script prompt)

Your responses (complete these 
actions)

Start installing ./dispatcher_install

By default, the name of the directory 
containing the Dispatcher is 
/usr/aw/COM/bin

This script installs the Dispatcher software 
package properly on each site. Before 
installation, decide on which machine to run 
the central spooler. 

Note the name of the machine as reported by 
the hostname command, then execute this 
script on every machine that is to handle a 
dispatched job.

/usr/aw/COM/bin
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When automount is running on the machine 
you are using, you should express the path 
relative to the symbolic link of the mount 
point. 

For instance, if the directory /usr/aw is 
automounted and is a symbolic link to
/tmp_mnt/usr/aw, you should give the 
name

/usr/aw rather than /tmp_mnt/usr/aw

Anomalies may occur at reboot time if this is 
expressed relative to the mount point of an 
automounted directory.

What is the proper name?

(default: /usr/aw/COM/bin)? 
/usr/aw/COM/bin

What is the name of the machine that will be 
the spooler? 

Instead of typing the name of the machine, 
you can use a period (.) to indicate this 
machine.

Enter the name of the spooler (machine1, or .).

Do you want verbose client listings in 

SYSLOG (yes|no)? yes

Do you want email notification of execution 
errors (yes|no)? yes

Installing the Dispatcher....

Do you want verbose spooler listings in 
SYSLOG (yes|no)? yes

Should the spooler notify of job termination 
by email (yes|no)? yes

Should the notification be verbose (yes|no)? yes

After the installation of the Dispatcher is 
complete, restart the Dispatcher in order for 
the newly installed program to take effect. 

To start the Dispatcher without rebooting, 
enter:
/etc/init.d/dispatcher start
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From now on, the Dispatcher starts at reboot depending on your 
chkconfig settings. You can set command line variables for: 

• dispatcherClient in the /etc/config/dispatcherClient.options 
file

• dispatcherSpool in the /etc/config/dispatcherSpool.options file

For example, on a spooler machine named machine1, type what appears 
in bold after the prompt:

machine1# 
/etc/init.d/dispatcher start

The Dispatcher is now ready for use, as you can see after you enter the 
following:

ps -ef | grep dispatcher

If the Dispatcher is properly installed and running, these lines should 
display:

root 21454    1  0 15:04:57 pts/4    0:00 /usr/aw/COM/bin/dispatcherSpool -v -M 
root 21455    1  0 15:04:57 pts/4    0:00 /usr/aw/COM/bin/dispatcherSpool -v -M 
root 21458  1  0 15:05:00 pts/4  0:00 /usr/aw/COM/bin/dispatcherClient -
smachine1 -v -E

To make the Dispatcher more secure, there are always two 
dispatcherSpool processes running. This means that end users can 
continue to use the Dispatcher even if one of the dispatcherSpool 
processes was disabled.

Troubleshooting dispatcher installation

This section contains troubleshooting tips for installing the Dispatcher and 
therefore concerns network administrator only. One of the quickest 
methods to get an explanation for a message and, if necessary, a course of 
action to correct the error is to figure out whether the problem is caused 
by a poorly installed or configured Dispatcher or by an error in the end 
user’s job. Problems are reported in the following ways:

• Problems concerning the dispatcherSpool or the dispatcherClient are 
reported as messages in the Console window (also sometimes in the 
shell window where the dispatcher is started), not as emailed 
messages to end users. 

• Problems caused by errors in jobs submitted to the Dispatcher are 
reported to end users by email. Examples of these kinds of problems 
are a mistyped directory path or an invalid script.

End users are advised to first look at their mail to determine the cause of a 
problem. If the email is not working, the next best place to look for 
possible clues is under the directory /var/spool/dispatcher. All the 
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messages from the individual machines are collected here and are 
normally emailed to end users. The full trace of all messages can be found 
in the file named SYSLOG (also oSYSLOG) under the /var/adm/ 
directory, but you must look in the SYSLOG of every machine. 

If a Component is missing

Once you have installed the Dispatcher on all participating machines, you 
can use the chkconfig command to turn the Dispatcher on or off at the 
next reboot. 

1 Check to see if all is correct by typing:

ps -ef | grep dispatcher 

You should find one instance of the dispatcherClient running on each 
client machine and two instances of the dispatcherSpool running on 
the spooler. If this is not so, especially on the spooler machine, try to 
start the missing component manually as follows. Open the Console 
window because it shows messages.

2 Change to the directory where your programs are installed.

3 Make sure that the dispatcherSpool is active on the spooler machine 
before you start any dispatcherClient. 

4 Start the dispatcherSpool without any command line parameters:

dispatcherSpool

The advantage of doing this is that any error messages are 
immediately displayed.

5 On the command line, start the dispatcherClient using the -s option:

dispatcherClient -s <spool_machine>

If the dispatcherSpool fails

The probable cause is poorly installed keys.

To find out what problem the Dispatcher has encountered, look in the file 
named /var/adm/SYSLOG. The Dispatcher generates many messages 
when it encounters a problem. Once you have done this (normally only 

Tip: For Steps 4 and 5, it is often quicker just to type the 
following line, but any problems occurring will not be 
indicated: 

/etc/init.d/dispatcher start
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once at configuration time, then you can ignore it), you can start 
configuring your pools and machines. The Dispatcher correctly sets the 
HOME and USER environment variables.

If a Frame is skipped

The Dispatcher dismisses the frame if it cannot execute on three different 
machines in your pool. It also refuses to re-execute a frame on a machine 
where it terminated in error. The most common cause of this is a typo in 
your script. Frames sent to a machine that is not working correctly (for 
example, a machine was rebooted) are re-routed to other machines.

How do you suspect that there is an error? 

If the Dispatcher runs through the whole frame range too quickly, you can 
suspect that an error has occurred. This can also happen if your job is too 
long and loops endlessly.

How do you figure out what went wrong? 

Encapsulate the script you wrote in another script you wrote and redirect 
the error stream to a temporary file:

#!/bin/csh -f
# on the next line I call up the script and redirect the error # output to a 
suitably named file that I can analyze at leisure # later
/usr/home/mydir/mysubmitscript $1 >& /usr/home/mydir/USED_‘hostname‘

If you do not receive email 

If the user doesn’t receive a report about a job, look in the /var/spool/
dispatcher directory. Either the email is not working or there is an error 
in the job. Normally, all the messages stored in that directory are emailed 
to the user. Also make sure that the spooler is not disabled.

Nothing seems to happen after submitting a job

After an end user submits a job, sometimes it may remain pending 
indefinitely in the bottom panel of the main Dispatcher window.

1 Check to see if each client, is running by entering on each client 
machine: 

ps -ef | grep dispatcher

Although the list of available machines appears in the Host 
Configuration window (you can see this by clicking to the right of the 
Host item), the dispatcherClient may not be running on one of these 
machines.
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2 If the dispatcherClient is not running on a particular machine, do a 
login (or do an rlogin) to that machine and type the following line:

/etc/init.d/dispatcher start

3 Cancel the job that you previously submitted and resubmit it in the 
Submit Job window. If the problem persists, continue with these steps.

4 Look in the /var/spool/dispatcher directory. Normally, messages 
appear here providing you with details about the jobs currently being 
executed. 

5 Because the settings in the Hosts Configuration window are 
important, make sure that the host is enabled and the Maximum Jobs 
is greater than 1. Also increase the Maximum Load even as high as the 
maximum of 10 in case any non-Dispatcher jobs are also running on a 
heavily loaded CPU. 

Path is not the expected path of the Dispatcher

Avoid typing the NFS part of the path to the dispatcher binary because 
typing the full remote path can cause problems. 

In the dispatcher.home file (found under the /etc/config/ directory of 
each machine the Dispatcher is installed on), the path identifying the 
location of the dispatcher, dispatcherSpool, and dispatcherClient binaries 
is possibly preceded by a NFS segment such as /tmp_mnt/. For instance, if 
the directory /usr/aw is automounted and is a symbolic link to /
tmp_mnt/usr/aw, you should type the name /usr/aw, not /tmp_mnt/usr/
aw. This means that you should type the path that is relative to the 
symbolic link of the mount point.

To see the contents of the dispatcher.home file, type:

more dispatcher.home

The path for the Dispatcher is given, for example, /usr/aw/COM/bin. To 
see what is stored under this directory, type:

ls /usr/aw/COM/bin

This directory contains the dispatcher, dispatcherSpool, and 
dispatcherClient binaries.

Console window error messages

Message

When you try to install the Dispatcher, an error message says:

“dispatchhost: Program not registered”
“machine: Program not registered”
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Action

Make sure the network is alive and well by issuing a /usr/etc/ping 
command. Also make sure the spooler is running on the named machine 
by entering:

ps -ef | grep dispatcherSpool

This message also appears when you type dispatcher and no 
dispatcherClient is running on that machine. Type:

ps -ef | grep dispatcherClient

You may also get this message if the Dispatcher is not installed on the 
machine where you tried to start the dispatcher. Make sure the machine 
where the spooler is installed is keyed for Alias software.

Message

164 The subprocess is not active.

Action

The dispatcher processes are out of sync. You must stop the existing 
dispatcher process before starting a new dispatcher process as follows:

/etc/init.d/dispatcher stop
/etc/init.d/dispatcher start

Message

spooler: Timed out

Action

Make sure that dispatcherSpool is running on the spooler. On the spooler, 
enter:

/etc/init.d/dispatcher start

This command makes the dispatcherSpool run. 

Message

“dispatchhost: Unknown host”

Action

Ensure:

Note: Make sure that the $HOST environment variable is set. For 
example, add the following line to your .cshrc if $HOST is 
not already set:

setenv HOST ’usr/bsd/hostname’
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• the Dispatcher is installed on your system.

• the client machine is attached to a spooler (enter 
dispatcher -s spooler_name on the command line to start the 
Dispatcher).

• the environment variable DISPATHCHHOST is defined in your 
environment.

• a machine is called or aliased as dispatchhost.

Progress window error message

Message

exec failed: No such file or directory

Action

The job you submitted was not found. Make sure the job can run when 
submitted directly in your shell; in particular, check that no argument is 
missing.

Change the configuration

After you use the Dispatcher for a while, you may decide that the options 
you chose at installation time are no longer exactly what you want. To 
make changes to the configuration settings, reset their values in files as 
described in this section.

Turn the Dispatcher on and off

Once you have run the installation script, the Dispatcher starts at machine 
reboot time. However, the network administrator, as root, can start or stop 
the Dispatcher at any time on any machine that has the Dispatcher 
software installed by entering:

/etc/init.d/dispatcher {start|stop}

Change the spooler

You can change the choice of spooler you supplied when prompted by the 
dispatcher_install script by designating another machine. An example is 
when you need to bring down a spooler to add more memory to it. 
Switching only affects the dispatcher component, not the dispatcherSpool 
or dispatcherClient components. In other words, when you switch a client 
machine to a different spooler, you are not stopping the original spooler.

There are two ways to change a spooler.

• Enter the following at the command line every time you start the 
Dispatcher:
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dispatcher -s<spooler_host>

Replace spooler_host with the name of the machine that you want to 
become the spooler. If you do not set the -s option on the command 
line, the dispatcherClient looks for the setting of the environment 
variable named DISPATCHHOST. You can also manually reset this 
environment variable by typing:

setenv DISPATCHHOST <hostname>

• Edit the dispatcherClient.options file that contains the spooler to be 
used by the client machines. This file is described in the next section.

To change the spooler

1 Edit the file by entering:

jot dispatcherClient.options

2 Change the spooler designation using the -s option. In this example, 
replace machine1 with machine2.

The original line is: -smachine1 -v -E

The new line is: -smachine2 -v -E

The Dispatcher gets the name of the spooler from this file.

3 Re-save the file.

4 Type the following line

/etc/init.d/dispatcher stop

5 Type the following line so the change you made in Step 2 takes effect.

/etc/init.d/dispatcher start

6 To make sure the change is in effect, enter:

ps -ef | grep dispatcher

The dispatcherClient -s with the name of the spooler you 
designated in Step 2 should be displayed.

All client machines must have a spooler so end users can start the 
Dispatcher.
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Use Dispatcher files

There are a number of files the Dispatcher needs to use in processing your 
jobs. The two most essential files are dispatcherClient.options and 
dispatcherSpool.options. 

You don’t have to edit these files very often. When you run the 
dispatcher_install script and use the default replies, many of these files are 
automatically specified for storing the Dispatcher’s data. 

/etc/config/dispatcherClient.options

This file stores information about which settings are in effect (for example, 
the email settings) and how detailed the email messages are. You can edit 
the file using the editor of your choice, for example, jot. To display the file, 
type the following:

jot /etc/config/dispatcherClient.options

After the installation of the Dispatcher, this file contains values that were 
set depending on your replies to questions asked during the installation.

Be careful about capital versus small letters. The capital E has a different 
effect than its smaller counterpart. A typical line in this file is:

Tip: To start the Dispatcher on a machine where the Dispatcher 
is not installed, you can type:

dispatcher -smachine

where machine is the name of another machine acting as the 
spooler. You can thus run the dispatcher component on a 
machine with none of the Dispatcher components installed 
on that machine.

Option Description

-v provides detailed messages in verbose mode 

-e provides limited reporting

-E provides full error reporting by emailing any error 
messages to the client

-s<spooler 
host>

determines which machine is the spooler
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-smachine1 -v -E

This means that machine1 is currently the name of the spooler host, 
detailed messages are produced, and full error reporting is requested.

/etc/config/dispatcherSpool.options

This file contains options that tell the Dispatcher whether to send an email 
message upon job termination. The values are set with the reply you gave 
when prompted by the dispatcher_install script, but you can change these 
values. To edit this file, you must be logged into the spooler. When you 
enter the following line on the spooler:

jot /etc/config/dispatcherSpool.options

You can specify the following options as a single line in the file:

/var/adm/SYSLOG

This standard IRIX file keeps several types of error messages, particularly 
if the dispatcherSpool fails. First, look at any emailed messages from the 
super-user, as these are more readable than the contents of the SYSLOG.

/var/spool/dispatcher

Like SYSLOG, this file also logs error messages.

/etc/dispatch.hosts

This file contains a list of the machines used by the Dispatcher and is for 
viewing only.

/etc/dispatch.pools

This file contains a list of the pools used by the Dispatcher and is for 
viewing only.

Option Description

-m provides a brief notification 

-M provides verbose notification including run times on each 
machine; useful for accounting purposes
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/etc/dispatch.host.data

This file contains a list of the values per machine and is for viewing only. 
The values shown are those that you can set in the Host Configuration 
window, corresponding to Maximum Load, Minimum Idle Time, 
Maximum Jobs, Execution Priority Offset, hours during which rendering 
is allowed, and any days on which rendering is not allowed.

Remove a client machine from a spooler

A situation may arise when you want to rename a client machine or 
remove one from your site. If the dispatcherClient program is running on 
each of these machines, you may want to update the list of machines 
appearing in the Host Configuration menu next to the Host item. 

To remove client machines from the spooler

1 Log onto the spooler as root, and type the following line:

/etc/init.d/dispatcher stop

2 Then type:

jot /etc/dispatch.hosts

3 In this file, either delete the name of the machine you want to remove 
or remove all the names of the client machines from the file. 

4 Save the file.

5 Type the following line:

/etc/init.d/dispatcher start

If you removed all the names in Step 3, the Dispatcher will 
automatically update the list.

For end users

Start the Dispatcher

If the Dispatcher is not installed at your site, ask the network 
administrator to install and configure the software for you. 

Tip: Steps 2 and 5 ensure that the changes you make to a file will 
take effect when you restart the Dispatcher. Otherwise, you 
will see no change in the list of machines viewable in the 
Host Configuration window.
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Setting up the Dispatcher is an important process that must precede using 
the Dispatcher for everyday operations since the setup involves making a 
number of important configuration decisions concerning the product and 
access to the product. See ”For network administrators” on page 16.

To start Dispatcher within Maya

1 Once the Dispatcher is installed, select Render > Distributed Render. 
The Distributed Render window appears from which you can select 
the Maya scene file you want to dispatch. You are prompted to save 
the scene file under the name of your choice. 

2 Click Distribute Render. The Dispatcher window and the Submit Job 
windows display. Use the Dispatcher by choosing items in the File, 
Hosts, Jobs, and Pools menus. 

When working with the Dispatcher, you create a pool, configure hosts for 
that pool, and then submit a job to the Dispatcher for execution. The job is 
distributed to the machines you allot to your pool. Each works on its part; 
the Dispatcher picks up the results from the machines as they finish their 
individual sections. For details on how to submit jobs, see “Submit a job”.

To start Dispatcher from a shell

When working in environments other than Maya, or if you want to 
dispatch without Maya’s graphical user interface, you should type the 
following in any shell:

dispatcher

The Dispatcher window appears. Once you have set up a pool and 
configured hosts, you can submit jobs. 

To accommodate different styles of working, the Dispatcher lets you 
submit jobs to a wide variety of applications. 

For details on how to submit jobs, see the sections appropriate for your 
work environment:

• Maya – ”Submit a Maya rendering job” on page 45.

• Studio – ”Submit a Studio job” on page 53.

• IPR – ”Submit an IPR rendering job” on page 54.

• Script – ”Submit a script via the Dispatcher” on page 54.

• Dispatcher command line – ”Submit a job from a IRIX shell” on 
page 56.
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Quit the Dispatcher

To end the current Dispatcher session

Select File > Quit (Ctrl-q). 

Dispatcher window

As an alternative to clicking the left mouse button or the middle mouse 
button, you may prefer to use the following keyboard shortcuts:

Keyboard shortcuts

Opening Dispatcher displays a window divided into three sections: File 
List, Contents Area, and View Area.

Keyboard key Action

Left arrow Moves one position to the left

Right arrow Moves one position to the right

Up arrow Moves one line upwards

Down arrow Moves one line downwards

Enter Validates and exits the window (same effect as 
clicking OK in windows)

Esc Same effect as clicking Cancel in windows

F4 Displays the menu for the active panel in the 
Dispatcher screen (tab to the panel you want) 

Tab Steps forward to the current item you want

Shift+Tab Steps backward to the current item you want

Ctrl-s Equivalent to selecting Jobs > Submit

Ctrl-i Equivalent to selecting Jobs > Info

Ctrl-q Leaves the Dispatcher (equivalent to selecting 
File > Quit)
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Top panel

host

Displays the machines on which jobs are currently being executed.

job

Displays the name of the job.

image

Displays the frame number being executed to indicate the progress of 
the rendering or compositing.

Middle panel 

This panel displays information about jobs currently being rendered or 
composited.

job

Displays the name of the job.

priority

This is the scheduling priority (the higher the number, the faster the 
job executes).

total

Displays the number of frame requested.

done

Displays the number of frames completed.

active

Displays the number of frames currently running.

pool

Displays the pool (a machine can belong to a named pool or to a 
system-wide pool named WholeSystem.

Bottom panel

job

Displays the names of the jobs waiting to be rendered or composited 
(including suspended jobs).

priority

Displays the order in which the jobs are to be rendered or composited; 
a job of 10 gets the most resources.
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pool

Displays the set of machines on which this job can be rendered or 
composited.

To use the Dispatcher window

Do either of the following:

• Double-click the active machine in the top panel to display the View 
Progress window for the machine.

• Double-click the active machine in either the middle or bottom panel 
to display the Job Information window for the selected job.

Configure a host

Before you submit your first job to the Dispatcher, you need to tell it how 
each machine in a pool is to be used. You enter this information in the 
Host Configuration window. Change this information only when you 
change your pool or the machines included in a pool. Dispatcher retains 
settings of machines between sessions.

Configure each machine to tell it how many jobs to accept, how low the 
load average must be for it to accept a new job, and how long it must be 
idle before accepting a new job.

Click the OK button to confirm your modifications for each machine; 
otherwise, you lose them. 

To configure a machine

1 Select Hosts > Configure in the main window to see the Host 
Configuration window. 

The settings shown in the window can vary according to the name of 
the host. Each new host is automatically added to the list.

2 Select the machine you want to configure by clicking in the scroll list 
to the right of Host.

3 Fill in the details for the host machine.

4 When you finish entering the settings for the host, click OK to 
validate. Otherwise, click Cancel to discard the settings. 

Tip: Click and hold the right mouse button over any active 
panel to see the pop-up menu.
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5 Repeat Steps 2 through 4 for each machine that you want to include in 
the pool.

Set Host Configuration options

In the Host Configuration window, you can set configuration options for 
machines by selecting the machine or machines you want to configure 
from the Host panel.

Extend or remove a selection

Two useful shortcuts:

• To extend a selection of hosts, Shift-click.

• To remove hosts from your selection, Ctrl-click the host names.

The Shift and Ctrl keys let you configure machines quickly. When you 
don’t use these keys, you have to select a host, then set the Minimum Idle 
Time, Maximum Jobs, Execution Priority Offset, Maximum Load, and so 
on—repeating the process for each machine in the pool. 

If you need to change the Execution Priority Offset and you don’t use the 
Shift and Ctrl keys, you have to go back and change the Execution Priority 
Offset of each host. 

If you do use Shift and Ctrl, you can just redefine that particular setting 
and the program updates all the appropriate hosts for you. For instance, 
you can change Maximum Idle Time to 2 instead of 5, and every host that 
you select with Ctrl or Shift changes that setting to 2.

Enabled or disabled

To enable a machine, choose Enabled. 

To disable a machine, Disabled. Turning on Disabled terminates any 
job currently running on that machine.

Use To

Shift-click Add to the list of hosts being 
selected

Ctrl-click Remove one or more hosts from the 
list of hosts being selected
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Restrict rendering times

Instead of dispatching jobs while you or your colleagues are using the 
machines in the pool, you can schedule jobs to run during your lunch 
hour or even after you leave for the day.

Minimum Idle Time

Sets the number of minutes a machine is inactive before it can accept a 
dispatched job. Move the slider to 0 for no idle time (this is the default 
value), and move it to any other value up to 30 minutes to lengthen 
the period of inactivity. 

Be particularly careful about the idle time. Pressing a key or moving 
the mouse sets the idle time of the machine to 0.

Maximum Jobs

Sets the maximum number of jobs you can input from this machine to 
the Dispatcher. The value ranges from 1 to 20 and is usually a even 
number. If the machine has lots of memory, increase the value you 
choose. Also, make sure that the number of jobs matches the number 
of processors on the workstation. For example, on a multiprocessor 
workstation, choose a value corresponding to the number of 
processors (this is usually a multiple of 4). The default value is 1.

Execution Priority Offset

Lets you assign a lower priority to a job relative to other jobs running 
on this machine only. The lower the value, the higher the priority of 
the Dispatcher job you are submitting. The default value is 0. For 
more details, see the man entry for the nice IRIX command by typing 
man nice.

Maximum Load

Corresponds to the average number of jobs in the run queue. Because 
this number includes any non-Dispatcher jobs running on the 
machine, this makes the CPU less available to the Dispatcher jobs. If 
you start non-Dispatcher jobs while the Dispatcher jobs are active, set 
a high enough value for the Maximum Load to include all jobs. You 
can set a decimal value. Maximum Load is the same as the load 
average in the uptime IRIX command; type man uptime for more 
details. You may also find the top IRIX command relevant; type man 
top. The default value is 1.

Tip: Avoid setting too low a value for Maximum Load, as this 
can prevent jobs from executing. 
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Create a pool

This step is optional. If you do not create a pool, all the machines in the 
network form the default pool and use the pool name WholeSystem.

Pools group similar machines for you to submit jobs to. For example, you 
can group machines with more than 512 megabytes of memory into a pool 
called BigMem. You can use BigMem for jobs needing that much memory. 
Another example is to have a pool for small rendering jobs and another 
for final rendering.

You can dynamically change the pool a job is assigned to as it is running. 
Select the job, then press Ctrl-i (you can also use Jobs > Info, or double-
click the selected job). You can edit all of the nongray fields.

To create a pool

1 Select Pools > Create Pool in the main window. The Create Pool 
window appears.

2 Name the pool you want to create.

3 Click the Create button to create the pool, otherwise click Cancel. 
Immediately after you create a pool, the Configure Pool window 
(described below) appears. Once you create a pool, you can use it 
from session to session.

Configure a pool

Use the Configure Pool window to select the machines you want to 
include in a pool.

To configure a pool

1 Select Pools > Configure Pool. 

The Configure Pool window appears.

2 Choose the pool you want to configure.

3 Select the machines to include in the pool. When a machine is selected, 
its name is highlighted by a black dashed outline. 

4 Click the OK button to validate the pool; otherwise, click Cancel to 
cancel any changes you made to the pool configuration. 

Deleting a pool

To delete a pool

1 Select Pools > Delete Pool. 

2 The Delete Pool window appears.
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3 To select a pool for deletion, select the name of the pool in the list. The 
name highlights.

4 Click the Delete button to delete the pool; otherwise, click Cancel to 
cancel the deletion of any pools. Any jobs in the queue of the deleted 
pool are automatically transferred to other machines in the default 
pool called WholeSystem.

Submit a job

After you supply the necessary information for the machines in the Host 
Configuration window, you can submit jobs to be rendered or 
composited. When you select Jobs > Submit, the Submit Job window 
appears. This is the centerpiece of the Dispatcher because it is the window 
most often used. Choose the settings you want used when a job is 
executed.

The job is put in a queue and run when system resources allow. You can 
submit jobs for several applications to the Dispatcher and are not limited 
to rendering. 

Although you can usually submit jobs from the Submit Job window, you 
can also submit them from a IRIX shell. Choose any of the following ways 
to submit jobs to the Dispatcher.

To submit a job from the Submit Job window

Do any of the following:

• Use the dispatch_maya_render command

• Use the Maya Render command

• Submit a Studio job

• Submit an IPR rendering job

• Submit a script via the Dispatcher

• Submit an imgcvt job

• Submit a di job

To submit a job from a IRIX shell window

You can submit jobs using the Dispatcher command line in a IRIX shell. 

Shell scripts are usually created when you want to perform a series of 
actions to each frame. Using this way to submit jobs is useful as you 
continue to learn the Dispatcher. 

See “Submit a job from a IRIX shell” for details.
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To submit a job with commands

Type the commands you want the Dispatcher to execute in the Command 
box. You can enter a variety of commands from different Alias 
applications. The commands you can enter are described for each 
environment.

In the Command box, you indicate which file will be executed upon 
submitting the job. Although the Dispatcher gives you the flexibility to 
read and write files from any location, it is important that you correctly 
specify the locations when entering job-submission commands.

In the box labeled Name, the name of each job you submit to the 
Dispatcher appears. Typically, this is named after the scene file you select 
in the Command box.

Start

Indicates the starting frame in a frame sequence. For example, in a 
scene file with 50 frames, you can make the render begin at frame 9 if 
you select a range within the scene file.

End

Indicates the ending frame in the frame sequence. 

Step

Sets the increment for the number of frames to advance through a 
frame sequence. 

Specifying the rendering order

To make the Dispatcher render frames in a certain order, select one of 
these options:

Incremental

Renders the frames from the highest to the lowest.

Decremental

Renders the frames from the lowest to the highest.

Binary descent

Renders the frames starting from the halfway point in a frame 
sequence, then which half of that half, and so on. This halving process 
is continued until all the frames are rendered.
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Choosing a pool

WholeSystem

Makes the job eligible for execution on all machines across the system 
(this is the default).

List of pools

Makes the job eligible for execution only on the pool that you have 
selected. 

Set the scheduling priority

Scheduling Priority

Sets the order in which the job will be executed. The higher the value, 
the sooner the job is executed. To change the scheduling priority, drag 
the slider to set a value from 0 (lowest) to 100 (highest). This is the 
urgency of a job relative to other jobs. In the bottom panel of the main 
Dispatcher window, jobs are arranged according to this number.

Submit jobs

When you have completed filling out the Submit Job window, you are 
ready to submit the job. Click Submit to submit it or Cancel if you want to 
exit the window. 

Even after you submit a job, you can continue to change settings in several 
windows, such as the Host Configuration window and the Submit Job 
window (keyboard shortcut Ctrl-s ). These changes take effect 
immediately for the jobs already submitted.

Submit a Maya rendering job

You can submit rendering jobs to Maya in two different ways:

• using the dispatch_maya_render command

• using the Maya Render command

The dispatch_maya_render command is often the most suitable for Maya 
users.

Tip: You can temporarily remove a machine from a pool by 
clicking the machine name in the list of machines in the 
Host Configuration window (Hosts > Configure) and 
turning on Disabled.
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dispatch_maya_render

dispatch_maya_render is a script used in conjunction with dispatcher 
to distribute rendering jobs across a network of computers.

Use the dispatch_maya_render command

The dispatch_maya_render command is included with Maya. This 
command speeds up rendering by dispatching packets of frames to a 
single machine via the packet parameter. Frames are collected into packets 
that allow optimized data access, eliminating multiple dispatches of each 
frame across several machines. This means that more time is spent 
rendering the data rather than ping-ponging each frame across several 
machines. A packet usually contains several frames (the default is 10).

To use dispatch_maya_render

1 Select Render > Distributed Render. The Distribute Render window 
appears so that you can select an existing scene file to render.

2 Click Distribute Render. 

You are prompted to save the scene file under the name of your 
choice or overwrite the original scene file. By default, the path 
displayed is relative to your current project, but you can change this 
to any path you want. Most users, however, will want to set a project 
so the data is more manageable (File > Project > Set).

The Dispatcher window and the Submit Job window display. By 
default, the dispatch_maya_render command appears in the 
Command entry of the Submit Job window. A typical line is 
something like the following:

dispatch_maya_render # 1000 100 -proj  /u/myname/maya/projects/Prod  
myanimation.ma

You must specify the hash sign (#). During execution, the hash symbol 
is replaced with the number of the current frame, repeated until all 
frames are rendered. The hash sign is followed by two numbers—one 
corresponds to the last frame, and the other corresponds to the 
number you specify in the Step field. Both numbers are required.

The Dispatcher uses the current project as set using File > Project > 
Set. With a current project set, the files are read from the scenes 
directory of the current project and are saved to the images directory 
of the current project. Assuming the current project is Prod, you can 
see that the path after the -proj option takes the name of the current 
project. Consider the following:

Note: dispatch_maya_render is only available for IRIX.
Rendering Utilities

46



2 | Dispatcher

About > Submit a Maya rendering job
• If you do not provide a path for the Maya file, it is read from the 
following directory:

 $HOME/maya/projects/default/scenes (IRIX)

Users/username/Documents/maya/projects/default/scenes 
(Mac OS X) 

• If you do not provide a path for the rendered images, they are 
stored in the following directory: 

$HOME/maya/projects/default/images (IRIX) 

Users/username/Documents/maya/projects/default/images 
(Mac OS X)

The last part in the Command entry is the name of the job being 
submitted. For example, anim.ma is the file containing the animation 
that you want to render. 

Users submitting jobs from an IRIX shell/Terminal or in scripts should see 
Effects of $MAYA_PROJECT settings on locating Dispatcher files.

View the Submit Job window the first time

The first time you click Distribute > Render, the Submit Job window 
appears with a Command entry line filled out. The -proj option is used 
so the Dispatcher can figure out the file locations.

Change items in the Command entry

The file to be submitted is specified without the path of the project. The 
Dispatcher searches for and finds the file in the scenes directory of the 
default project.

The settings in the Submit Job window are preset to those used for the 
most recently submitted job, but the Start, End, and Step values 
automatically correspond to those set in Render Global Settings window 
(select Window > Rendering Editors > Render Globals) or on the time bar 
for the script about to be submitted. You can control the animation range 
in the Animation section of the Render Global Settings window by 
toggling between Start/End and Render Globals. 

Display the Start and End frames

The Start, End, and Step values initially displayed in the Submit Job 
window are derived from the settings in the Animation section located 
under the Render Global Settings window.
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Include Maya Render command options

You can use Maya’s Render command options as arguments of the 
dispatch_maya_render as you would using the Render command.

dispatch_maya_render options

Specifying dispatch_maya_render options

Jobs can be dispatched using the following command:

dispatch_maya_render # <endframe> <packet> <Render_options> scene

where: 

#

Holds a place for the frame number; must be specified as is. (The 
Dispatcher uses the hash sign (#) to indicate the current frame.)

endframe

Indicates the last frame in the animation as it appears in Render 
Global Settings window under the Animation section.

packet

Defines the size of the packets into which you are dividing your scene 
file for dispatching. The default is 10. Packets may have different 
number of frames. You do not enter the word packet, just a number 
that is the same value as Step. You should define the packet size in 
relation to the number of frames in your animation. For example, if 
you have a 600-frame animation, you can set the packet size to 20 or 
30.

Render_options

Are the command-line options for Maya’s Render command; you 
must at least give the name of the Maya file to render. To see these 
options, type the following in any shell:

/usr/aw/maya5.0/bin/Render -help

For example, the -proj option is set by default to the images directory 
and the scenes directory of the current project. The paths are 
displayed in the Command entry automatically when you select Jobs 
> Submit but you can change these if you prefer. The default structure 
in Maya uses the subdirectory names images and scenes, but you can 
also change these. The -proj is a command-line option for Maya's 
Render command.
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You use the Start, End, and Step settings to control the sequence of 
images to be rendered. Make sure to enter the starting and ending 
frames as defined in the scene file.

Start

Indicates the starting frame in a frame sequence. 

End

Indicates the ending frame in the frame sequence. You must place this 
number immediately after the hash sign.

Step

Sets the increment for the number of frames to advance through a 
frame sequence; must be the same value as the packet size (this is the 
second number after the hash sign). 

Example of a Maya rendering job

In the following example, images are rendered in five-frame packets (the 
Step, and therefore the packet, is 5). In the Submit Job window after the 
word Command, enter the following:

dispatch_maya_render # 50 5  -rd /u/yourname/outdir/ /u/
yourname/maya/myproject/scenes/myanim

50 is the last frame in the animation and the Dispatcher step frame is 5 (as 
opposed to the Step Frame in the Render Global Settings window).

In this example, the -rd option overrides the -proj option.

You can see the separate packet streams in the Progress window 
(Hosts > View progress). Once you set up the Dispatcher correctly and test 
your command, you will see that the dispatch_maya_render command is 
an efficient way to render images. The Dispatcher runs in the background 
and does not require the Maya interface. To see the full list of 
dispatch_maya_render options that are available to you, type in a shell:

dispatch_maya_render -help

Use the Maya Render command

You can dispatch rendering jobs using the Maya Render command and 
specifying all the usual batch rendering command line options. 

This is for Maya users only.

Note: The dispatch_maya render command can be used only in 
the Submit Job window. 
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To submit a job

1 Select Jobs > Submit (Ctrl-s). 

The Submit Job window appears.

2 Fill in the name of the job you want to submit to the Dispatcher. This 
can be the name of a scene file that you want to execute. Names 
separated by empty spaces are not accepted.

3 Enter the syntax of the command that you want to input to the 
Dispatcher. 

What you type for this entry changes according to the type of 
command you want to execute. For a Render command (similar to the 
Maya Render command line), you must enter the hash character (#) 
after the -s and -e options. During execution, the hash symbol is 
replaced with the number of the current frame, repeated until all 
frames are rendered. This convention allows the Dispatcher to run a 
rendering job without knowing anything about the actual data to be 
rendered. 

The Dispatcher is designed for post production jobs as well as 
rendering jobs. When using the Render command, don’t confuse the 
hash characters with the execution of a sequence of images in Render.

4 Indicate the Start, End, and Step values as desired. Make sure to enter 
the starting and ending values as defined in your script. Otherwise the 
last frame is repeated until the ending number you choose is reached.

The Dispatcher executes a series of frames, beginning at the starting 
frame and executing frames based on the Step counter until the 
ending frame is reached (the Start or End do not necessarily 
correspond to an image).

Tips: • Normally, the Render command is in your path (the 
network administrator arranges that the command points 
to the correct location). If not, instead of typing Render, 
you should type:

/usr/aw/maya5.0/bin/Render

• To see the full list of options that are available to you when 
you are using the Render command, type Render -help in 
a shell.

• For Render commands only, always specify the -s # -e #  
-b 1.
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For example, if you have a 100-frame rendering job and you enter the 
command Render -s # -e # -b 1 myscene, then specify a starting 
frame of 10, an ending frame of 100, and a step of 1, all the frames 
between 10 and 100 are processed. 

The Dispatcher controls frame execution using the hash character (#). 

First frame 10 is passed to:

-s # -e # -b 1

which is filled in as:

-s 10 -e 10  -b 1

then frame 11 is passed to:

-s # -e # -b 1 

which is filled in as:

-s 11 -e 11  -b 1. 

This continues until -s 100 -e 100  -b 1 is executed. Of course, if 
you specify a step of 2, only half the frames between 10 and 100 are 
executed.

5 Rearrange the order in which you want frames to be rendered by 
clicking the Order button.

6 For Pool, select WholeSystem (this is the default) or any pool you have 
defined.

7 Choose a number for the scheduling priority by moving the slider. 
The scheduling priority range is from 0 (lowest) to 100 (highest).

8 Click Submit to validate the job; otherwise, click Cancel.

Tip: Avoid pressing Enter to confirm a value in the Step or End 
boxes as it is interpreted as meaning OK, causing the job to 
be submitted immediately.

Tip: Avoid specifying the /usr/tmp directory as the output 
destination for your images because the images may be 
stored locally in the /usr/tmp directory of each machine 
used by the Dispatcher instead of in the /usr/tmp directory 
of the submitter’s machine.
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Effects of $MAYA_PROJECT settings on locating 
Dispatcher files

The following table shows how changing the $MAYA_PROJECT 
environment variable affects where files are read from and where they are 
saved. 

The following table showsappears how to keep track of files. This can be 
especially useful when entering commands from the command line or 
running scripts in the Dispatcher. 

(For Maya users only.)

$MAYA_PROJECT Means

Is not set Sample command: Render myscene.ma

File is read from: $HOME/maya/projects/default/scenes/

Resulting images are 
stored in: 

$HOME/maya/projects/default/images/

Is set in the .cshrc or 
.tcshrc or in a shell

Sample command: Render myscene.ma

File is read from: $MAYA_PROJECT/scenes/

Resulting images are 
stored in:

$MAYA_PROJECT/images/

Is set in the Render 
command only, 
overriding any other 
settings such as those 
in the shell window

Sample command: Render -proj $HOME/maya/projects/New  
myscene.ma

File is read from: $HOME/maya/projects/New/scenes/

Resulting images are 
stored in:

$HOME/maya/projects/New/images/

Sample command: Render -proj $HOME/maya/projects/New 
/usr/tmp/myscene.ma

File is read from: /usr/tmp/myscene.ma

Resulting images are 
stored in (as defined 
by -proj):

$HOME/maya/projects/New/images/
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Submit a Studio job

Use the Dispatcher to render images in the Studio environment using the 
dispatch_render command. This program is provided in Studio for 
rendering a sequence of frames defined with the stepvalue parameter. The 
Dispatcher will replace the hash character (#) with the current frame 
number by the Dispatcher at runtime.

Use the following line to set the parameters:

dispatch_render # stepvalue renderer options [startFrame endFrame byFrame]

startFrame, endFrame and byFrame are only needed when the byFrame 
has a value other than 1.

This line produces a system call to one of the renderers. 

In the following example, the byFrame is 1, meaning the last three 
optional parameters are not needed in the command. In the Submit Job 
window after the word Command, enter the following:

dispatch_render # stepvalue raytracer "-p OUTPUTFILE SDLFILE"

This results in a system call to perform the following:

raytracer -sX -eY -p OUTPUTFILE SDLFILE

where:

X = current frame as passed on by the Dispatcher

Y = X + (stepvalue - 0.05)

Is overridden by 
absolute pathnames 

Sample command: Render -proj $HOME/maya/projects/New 
-rd /usr/tmp myscene.ma

File is read from: $HOME/maya/projects/New/scenes

Resulting images are 
stored in:

/usr/tmp/

Sample command: Render -rd /usr/tmp/ /usr/tmp/
myscene.ma

File is read from: /usr/tmp/

Resulting images are 
stored in (even if the 
$MAYA_PROJECT is 
set):

/usr/tmp/

$MAYA_PROJECT Means
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You use the Start, End, and Step settings to control the sequence of images 
to be rendered. Make sure to enter the starting and ending frames as 
defined in the script.

In the script, you can specify the directory where the scene files are stored 
by typing:

$ALIAS_WORKENV/sdl/scene1

To make the script more useful:

• Specify an output directory for storing the final rendered images. For 
example, enter:

-p$ALIAS_WORKENV/pix/rendered_images 

• Keep a log of the images being rendered by redirecting the output of 
the Renderer to a file. In your script, include the following line (you 
must type the following two lines as a single line without pressing the 
Enter key after the first line):

renderer -s$1 -e$1 -b1 -p$ALIAS_WORKENV/pix/
rendered_images $ALIAS_WORKENV/sdl/scene1 >>& 
$ALIAS_WORKENV/rendering_trace

Once you set up the Dispatcher correctly and test your script, you will 
find that the Dispatcher is an efficient way to render images regardless of 
the environment you are using.

Submit an IPR rendering job

Use the Dispatcher to render a sequence of images in the IPR environment 
using the render program provided in IPR. 

For example, if you have a 100-frame rendering job and you enter the 
command render -n # # 1 myjob, then specify a starting frame of 10, 
an ending frame of 100 and a step of 1, all the frames between 10 and 100 
are executed. 

The Dispatcher controls frame execution using the hash character (#). First 
frame 10 is passed to -n # #, which is filled in as -n 10 10 1; then frame 
11 is passed to -n # # which is filled in as -n 11 11 1. This continues 
until -n 100 100 1 is processed. Of course, if you specify a step of 2, only 
half the frames between 10 and 100 are executed. 

Submit a script via the Dispatcher

You can use the Dispatcher to execute scripts that contain any commands 
you want. For example, you can use scripts for compositing tasks by 
incorporating a command in the script. The following three scripts for 
Maya, Studio, and IPR provide instructive examples for rendering images.
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Sample script for running in Maya

This sample script contains the following lines for running in Maya.

#! /bin/csh -f
setenv MAYA_PROJECT /u/robert
Render -s $1 -e $1 -b 1 -p Test Scene.ma

The convention of using a dollar sign followed by 1 is normal after the -s 
and the -e options. A fast way to create a script is to modify an existing 
one. 

The output images are named Test as indicated by -p Test.

Maya assumes the Scene.ma file is located in the scenes directory of the 
current project. The MAYA_PROJECT variable defines the directory 
where the scene is stored. The MAYA_PROJECT variable is set to the /u/
robert directory.

Sample script for running in Studio

This sample script contains the following lines for running in Studio.

#! /bin/csh -f
setenv ALIAS_WORKENV /v/pierre
setenv ALIAS_PROJECT world
set projpath = $ALIAS_WORKENV/user_data/$ALIAS_PROJECT
# sdl name
set SDL = star
# renderer or raytracer
set R = renderer
${R} -s $1 -e $1 -b 1 $projpath/$SDL

In the script, you can specify the ALIAS_WORKENV and ALIAS_PROJECT 
variables to define where the project data is stored. Doing this overwrites 
the settings of your .cshrc file. You can also define the scene you want to 
render, as well as the rendering program you want to use.

You can make the script more useful if you:

• Specify an output directory for storing the final rendered images. For 
example, add the following:

-p /a/stockImages

• Keep a log of the images being rendered by redirecting the output of 
the Renderer to a file. In your script, include the following line (you 
must type the following two lines as a single line without pressing the 
Enter key after the first line). 

${R} -s $1 -e $1 -b 1 -p /a/stockImages $projpath/sdl/
scene1 >>& $ALIAS_WORKENV/rendering_trace

Sample script for running in IPR

IPR users would write a script such as the following:
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#! /bin/csh -f
setenv MY_OUT /a/stock1
render -v -A -I -l 768 576 -n $1 $1 1 -i $MY_OUT/my_outimage
my_scene_file

You can also specify the -W and the -P options when working in the 
Explore environment.

To run a script via the Dispatcher

1 Create a script acceptable to your environment. See the preceding 
sample scripts for Maya, Studio, and IPR users.

2 Save the script under a name such as myrender1. Make a note of 
where you save it. In this example, the directory is called /u/robert 
but you can choose any directory you want.

3 Set the protection for the file named myrender1 to make it executable 
by entering:

chmod a+x myrender1

4 In the Submit Job window in the Dispatcher, enter the following:

/u/robert/myrender1 #

Make sure to give the path of the directory where your script to be 
executed is stored. The hash sign (#) in the command line will be 
replaced by the number of the frame you are rendering. In the script 
you have just written, this is the argument number 1 (the references to 
$1 in the script).

Use the Start, End, and Step settings to control the sequence of images 
to be rendered. Make sure to set the starting and ending frames so 
that they match those defined in the script.

5 Click Submit.

Submit a job from a IRIX shell

Submitting jobs from a IRIX shell refers to dispatching jobs using 
previously set options, such as the pool, without entering the Dispatcher 
user interface. For example, typing the following command in a shell lets 
you submit a job. 

dispatcher -n 1 10 1 -j myjob -c “sleep 5 ; echo Frame.#”

The Dispatcher processes the job, and when it is completed, sends email 
confirming the results. The job is completed without any of the 
Dispatcher-related windows being displayed. This is a more effective way 
of working. If you write your own scripts for dispatching jobs, you will 
find this feature useful.
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Typing the following command in a shell and specifying the -g option lets 
you display the Dispatcher window and the Submit Job window in case 
you want to make changes before submitting the job:

dispatcher -n 1 10 1 -j myjob1 -g -c “sleep 5 ; echo 
Frame.#”

All items immediately following the -c option up to the end of the line 
correspond to the actual command issued to the Dispatcher. In the above 
example, this part of the line corresponds to issuing the following 
commands:

sleep 5 ; echo Frame.#

You can use the echo Frame.# command to display additional 
information in the Progress Window. To render a Maya script called /u/
alain/MyMaya for the first hundred frames, do the following:

dispatcher -n 1 100 10 -c dispatch_maya_render # 100 10 
-proj /u/alain/ MyMaya

For this command to work, it is assumed that you can run Maya. Also, the 
number after the hash (100 in this example) is the same as the end frame 
number (-n 1 100 10) and the second number after the hash (10 in this 
example) is the same as the step number (-n 1 100 10).

To edit the settings in the Submit Job window before submitting the job, 
enter the following line:

dispatcher -g -n 1 100 10 -c dispatch_maya_render # 100 10 
-proj /u/alain/ MyMaya

You can even use these lines in a script to dispatch jobs. 

Specify Dispatcher command-line options

Use the following line at the Command prompt in any shell on a machine 
that has the Dispatcher program installed:

dispatcher <options>

where <options> is one or more of the options in the following table:

Use... For...

-help listing a summary of the syntax.

-vers finding out which version of the Dispatcher you are running.

-banner preventing the banner from displaying.

-s <spooler_name> specifying the spooler you want to connect to.
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Submit a non-rendering job

Choose a command to enter in the Command-line entry. For example:

• The IRIX command sleep 12 is entered as the command (you can 
enter any IRIX command you want).

• The job contains five frames: Start is 1 and End is 5.

• The order in which the job was submitted is incremental.

• The pool is named WholeSystem, 

• The scheduling priority is 1. 

• Click Submit to submit the job.

Submit an imgcvt job

This example is of an imgcvt job to convert images from one file format to 
another. The single-line command entered in the Command entry is:

imgcvt -f sgi -t jpg /u/robert/maya/projects/New2/images/my_images.sgi.# /u/
robert/maya/projects/New2/images/my_images.jpg.#

-p <poolname> specifying the pool you want to use.

-j <jobname> specifying the job name.

-n <start> <end> 
<step>

defining the starting and ending frame in a script as well as the 
number of frames the script is incremented by. For example, 
specifying -n 1 10 1 means start at frame 1, and go to frame 10 in 
steps of 1.

-g displaying the Dispatcher graphical user interface. For example, 
when you are dispatching jobs in batch mode, you may need to 
display the Submit Job window to change parameters before 
submitting a job.

-c <command> indicating that everything immediately following the -c option up to 
the end of the line is the actual command that will be submitted to the 
Dispatcher. The -c option must be the last option you specify.

Use... For...

Tip: An effective way to test the Dispatcher is to submit simple 
IRIX commands such as sleep.
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Submit a di job

This example is of a di job to resize images. The single-line command 
entered in the Command entry is:

di -s 768 576 -w /u/robert/maya/projects/New2/images/resized_image.# /u/robert/
maya/projects/New2/images/initial_image.#

View progress

Once you have submitted jobs for execution, follow these steps to monitor 
useful information about jobs running on hosts.

To view progress

1 Select Hosts > View progress. A window appears showing the 
progress of the rendering or the compositing.

2 Select File > Save As to save the contents of the window to a file of 
your choice. This allows you to keep a trace of important messages.

3 Select Display > Filter Error Messages to filter out anything beginning 
with a warning. This allows you to focus on critical events.

4 Select File > Close to exit.

Get job information

Select Jobs > Info (Ctrl-i ) to display an information window with a 
description of the job. The Dispatcher opens the window so you can still 
change the scheduling priority and the pool while you work. In the 
window, the Pool and Priority settings appear in white, meaning that you 
can change them. The ability to change the Pool and Priority settings is 
especially important here as the new settings have an immediate effect. 
For example, you can process jobs faster by moving the slider to change 
the Priority.

Setting the priority to 0 suspends a job, whereas setting the priority to any 
other value will restart the job.

Get an emailed report

As soon as a job is completed, you receive an email message informing 
you that it has finished. For this to work, your network administrator 
must ask for email notification of job termination as described in “Run the 
installation script”. 

The example shown here works in the Maya environment only. the 
following is the command that was entered in the example (all on a single 
line).
Rendering Utilities

59



2 | Dispatcher
About > Suspend or restart a job
Render -s # -e # -b 1 -x 100 -y 100 -rd /u/myname -cam persp -p perspImage /u/
myname/scenes/myanim.ma

This is the report produced after the job named myjob was submitted.

JOB REPORT PAGE 1                      48_myjob
This report was generated by filtering the log of your job with the program /
var/spool/dispatcher/dispatcher_format. You can copy this file into your own 
directory, edit it, and call it .dispatcher_format to make it your own.
requested   1    to   20   by 1
job status OK 1 successful frame, aggregate time 419      seconds total 
accumulated time: 14 seconds of which 0 in error
job status OK 20 successful frames, aggregate time 138 seconds
total accumulated time: 396 seconds of which 0 in error

Suspend or restart a job

You can put a job you are running on hold until you resume its execution. 
You can do this by selecting Jobs > Suspend/Restart. This gives the job a 
scheduling priority of 0. 

You can resume a suspended job by selecting Jobs > Suspend/Restart, 
which sets a priority other than 0 for that job. 

Test a job

You can test your user environment, your machines, and the commands to 
be passed from one machine to another by typing the following line in a 
shell window.

rsh <machine> which <command>

where <machine> is the name of a machine at your site and <command> 
can be any of those listed in the following table.

Machine OK_Frame Errors Total Time 
(secs)

Error Time 
(secs)

corona 5 0 23 0

grenade 8 0 68 0

navet 3 0 79 0

potiron 2 0 133 0

raisin 2 0 93 0
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This test checks your environment where the Dispatcher is to run, 
whether your jobs coming across the network are accepted on a remote 
machine, and whether a particular command can be successfully used. By 
changing the name of the machine (you can also change the command), 
you can test a job on different machines that have the Dispatcher installed 
on them. 

Cancel a job

You can permanently remove a job from the list of jobs to run. To do this, 
select Jobs > Cancel.

In some situations, you may want to terminate a job before it is completed, 
no matter what its status is. For example, you might suspect that there is 
something wrong with the job (it is consuming too much CPU time) or 
that it requires resources that you know are not available. You can cancel 
a job at any time.

Environment Command Remarks

Maya rsh machine which Render

rsh machine which maya

rsh machine which dispatch_maya_render

rsh machine maya -h Checks whether the key 
exists.

Studio rsh machine which dispatch_render

rsh machine renderer -i Checks whether the key 
exists.

IPR rsh machine which render

Important

To be sure the Rendering or compositing programs are 
installed on each machine in the pool you are using, you 
should ask your network administrator. Otherwise, you 
will not get expected results when you run the command or 
script via the Dispatcher.
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About FCheck

Overview of FCheck

FCheck is an image and sequence viewer that caches images in RAM so 
you can play back and scrub images in real time. Color correction, image 
editing and error checking can be done in FCheck using tools that can: 

• display emboss, the negative, and image borders 

• adjust luminance, gamma, saturation, and offset settings

• change size, resolution, and magnification

• switch between RGB channels 

FCheck is installed with Maya and works on all supported platforms. 
Maya uses FCheck as an image previewer to display intermediate results 
of a rendering. It can be invoked directly from Maya or standalone. 

FCheck features can be enabled through command line options, hotkeys, 
the playback windows menus, mouse usage and the FCheck Info window 
on Mac OS X. 

For more information on hotkeys and command line usage, see ”FCheck 
features” on page 65.

For more information on mouse usage, see ”FCheck Mouse controls” on 
page 90.

For a lists of FCheck command line options, see ”FCheck” on page 77.

FCheck windows

FCheck displays two windows. The FCheck Playback window appears on 
all platforms and displays images or sequences you open. Depending on 
the platform, the menu items in the Playback window are different. 

Note: The offset, bump, color and negate commands are not 
available for FCheck on Mac OS X. 
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For information on the menu items of Windows and Mac OS X, see 
”Windows and Editors” on page 77.

For information on viewing options and adjusting settings, see ”FCheck” 
on page 77.

Windows/Linux/IRIX

Along with the playback window, a FCheck command prompt window 
appears to display image information. Image information is displayed on 
Linux and IRIX in the shell window used to open FCheck. 

Mac OS X

The FCheck Info window is unique to Mac OS X. Use it to control and 
modify the image or animation.

Playback window

Info window (Mac OS X)
Rendering Utilities

64



3 | FCheck

About > Overview of FCheck features
For information on mouse controls, see ”FCheck Mouse controls” on 
page 90.

FCheck features

Overview of FCheck features

You can use FCheck to alter the view and look of a pre-rendered image or 
animation sequence. For example, you can adjust luminance, gamma, and 
saturation. FCheck has features that can be accessed through:

• command line options. See ”FCheck options” on page 65.

• hotkeys. See ”Hotkeys” on page 66.

• using the mouse. See ”FCheck Mouse controls” on page 90. 

• toolbar buttons. See ”FCheck Control Bar” on page 90.

• the menu interface on some platforms. File menus in Windows and 
Mac OS X versions let you open and save images or sequences.

• the info window on Mac OS X. It is used to apply features that are 
otherwise unavailable on Mac OS X. See ”Mac OS X” on page 64.

FCheck options

Using options

FCheck options are a set of FCheck features operated using command 
lines. The options are typed into the command prompt window/shell 
window when FCheck is executed. 

The standard convention to enter a command line is given below: 

fcheck -<option> <spec> myimage.ext

<option>

The FCheck option letter. See ”FCheck options list” on page 77. 

<spec>

Option-specific parameters.

myimage.ext

Note: When re-opening FCheck, please note that FCheck does not 
remember options set in previous executions. An image 
must be written to disk to retain image modifications and 
adjustments executed in FCheck. See ”Save images or 
sequences” on page 74.
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The name of the file to load. You must be in the current directory in 
the command prompt to open the file. When using IRIX or Linux, you 
must include the filename to the command line. Otherwise, when 
using Windows or Mac OS X, you can omit the filename from the 
command line.to start FCheck with certain settings without opening a 
file.

For example:

fcheck -r 15  

Where r specifies the frame rate option and 15 is the number of 
frames per second.   

You can combine some options together in one command line using 
the following convention:

fcheck -<option> <spec> -<option> <spec> ... myimage.ext

For example, 

fcheck -B -G 1 -r 15 myimage.ext

Where:

-B turns on border around the image.

-G 1 sets gamma value to 1.

-r 15 sets frame rate to 15 frames per second.  

For the list of options with full descriptions, see ”FCheck options list” on 
page 77.

Hotkeys

Hotkeys refer to the combinations of keyboard keys that perform a 
program feature. 

The categories of features provided using hotkeys are: display keys, image 
adjustment keys, and animation playback control keys.     

Some hotkeys are not available in the Mac OS X version of FCheck.

Display keys

Display keys let you change the view of the image displayed in the 
FCheck playback window. Using display keys, you can: display different 
color channels, display borders of image tiles, zoom in and out, and 
display the image mask. 

For a full list of display keys, see ”Display keys” on page 80.
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Image adjustment keys

Image adjustment keys allow you to modify the properties of an image. 
Some useful image adjustment keys are: increasing and decreasing 
luminance, saturation, gamma, and offset values. 

For a full list of image adjustment keys, see ”Image adjustment keys” on 
page 82. 

Animation playback control keys

Use animation playback control keys to control the playback of 
animation/sequences of files. Some features you can perform using 
animation playback control keys are: forward play, reverse play, pause, 
adjusting the speed of playback, and toggling to the first frame.

For a full list of animation playback control keys, see ”Animation 
playback control keys” on page 85. 

Frame numbering and padded numbers

Understanding the concept of frame numbering and padded numbers will 
assist you in knowing the conventions for file opening and saving when 
dealing with an image sequence or animation.

Whenever a sequence of images is generated, a numbering convention is 
used to number frames. Padded numbers are frame numbers that have a 
specified number of digits, where 0s are used to fill the unused digits.   

For example, 

5 digit padding

myimage00002.ext 

Unpadded

myimage2.ext

FCheck uses different conventions when opening and saving files with 
padding. 

Convention for opening files

When opening files using the command line, a different convention is 
used to specify a file sequence. 

Depending on the position of the frame number in the filename, a 
different convention is used to indicate the file you are opening. 

The @ and # symbols are used to specify the position of frame numbers in 
filenames. The number of @ is parallel to the amount of padding in the file 
name.
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@
padded one digit

@@
padded to 2 digits (for example, 1 becomes 01, 10 remains 10)

@@@
padded to 3 digits.

#
is a shortcut for @@@@

The following is a list of sequence formats you can open, where @ 
represents the position of the frame number:

myimage@.ext
myimage.@.ext
@myimage.ext
myimage.@
myimage.ext.@

For example, if you want to open a sequence of files beginning with 
myimage.001.iff. You would enter the following command line:

fcheck -<option> myimage.@@@.iff

For details on how to open image sequences, see ”Open image sequences” 
on page 72.

Convention for saving files

By default, FCheck saves sequences of images without padding, counting 
from 1 to the number of frames. For example, FCheck names a 10-frame 
sequence from myimage1.iff to myimage10.iff. 

Using the # symbol, you can indicate the position and the amount of 
padding in the frame number when saving a sequence of images. 

You can save sequences using the following frame/animation formats:

myimage#.ext
myimage.#.ext
#myimage.ext

Use multiple #s, to set the number of padding in the frame number. One # 
represents one digit in the frame number. For example, myimage##.ext 
applies two number padding to the sequence.

For details on how to save files, see ”Save images or sequences” on 
page 74.
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How do I? Use FCheck

Start FCheck

To start FCheck on Windows

Do one of the following:

• From the Start menu, select Start > Programs > Alias > Maya 6.5 > 
FCheck. 

• Open <drive>\Program Files\Alias\Maya\bin folder and double-
click the FCheck application.

• Open the command prompt and enter fcheck.

The FCheck playback window and command prompt window appears.

To start FCheck on Mac OS X

In the /Applications/Alias/maya6.5 folder, double-click FCheck. 

The FCheck Playback Window and FCheck info window appears. 

The FCheck info window and keyboard shortcuts listed in the tables at the 
end of this chapter allow you control the image or animation in the 
FCheck Playback window.

To start FCheck on Linux or IRIX

In a shell window, type FCheck followed by the name of the image you 
want to display:

fcheck -<option> myimage

For a list of options, see ”FCheck options list” on page 77

You can display several images at once using wildcards (that is, *). Enter 
the following to displays all images whose names begin with the 
characters mytest:

fcheck mytest*

Each image appears in a separate window. 

Tip: You can click-drag the FCheck icon from a Finder window 
to the Dock to create a shortcut to the application.
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For an animation, you can use the dot extension (.) and FCheck 
automatically finds the start, end and step values for the sequence. Enter 
the following to display all images whose names begin with the characters 
mysequence in a single window:

fcheck mysequence.

On IRIX and Linux, you must specify a file to open.

For information on using the command line with a sequence filename, 
please see ”Convention for opening files” on page 67.

Open a file in FCheck

To open a file in FCheck on Windows

1 Start FCheck. 

For more information, see ”To start FCheck on Windows” on page 69.

2 In the Playback window, choose either File > Open Image or File > 
Open Sequence. 

A file browser appears.

3 In the file browser, select an image or the first frame of the animation 
sequence you want to view and click Open. 

The image or animation appears in the FCheck Playback window.

4 Manipulate the image or sequence using keyboard commands.

For more information on keyboard commands, see ”FCheck” on 
page 77.

To open a file in FCheck on Mac OS X

1 Start FCheck. 

For more information, see ”To start FCheck on Mac OS X” on page 69.

The FCheck Info window and the FCheck playback window appear.

2 In the File menu, choose either Open Images or Open Sequence. 

A file browser appears.

3 In the file browser, select an image or the first frame of the animation 
sequence you want to view and click Open. 

The image or animation appears in the FCheck Playback window.

Tip: You can also open a file in Windows using the command 
line. Follow the steps in ”Opening an animation using the -
n option” on page 72, for more details
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4 Manipulate the image or sequence by clicking on the options in the 
FCheck Info window or using keyboard commands.

For more information on keyboard commands, see ”FCheck” on 
page 77.

To open a file in FCheck on Linux or IRIX

1 Start FCheck with an image or a sequence.

For more information, see ”To start FCheck on Linux or IRIX” on 
page 69.

2 Manipulate the image using keyboard commands.

For more information on keyboard commands, see ”FCheck” on 
page 77.

You can display your image at full screen size by choosing View > Full 
Screen.

Control animation playback in FCheck

To play animation in FCheck 

1 Start FCheck

For more information, see ”Start FCheck” on page 69.

2 Open an animation or a sequence of images>

For more information, see ”Open a file in FCheck” on page 70.

3 Press any of the following to control animation playback: 

Note: The FCheck Info window numbers the selected image as 1, 
and all following frames in the animation accordingly. This 
numbering may not be the same as the numeric part of the 
image’s filename. For example, if you select frame 4 of an 
animation as the start frame in the FCheck window, the 
FCheck info window identifies frame 4 as frame 1. See 
”Image adjustment keys” on page 82.

Tip: Using FCheck, you can open and view renderings in 
progress. To update a partially completed image in the 
FCheck Playback window, use the “u” hotkey. See ”Use 
FCheck with Maya” on page 76 for using FCheck with 
Maya.

. <period> forward play 
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In addition, Mac OS X allows playback control using buttons within 
the Info window. 

For more information on sequence playback controls, see ”Animation 
playback control keys” on page 85.

Open image sequences

Opening an animation using the -n option 

The option -n allows you to open an animation, while specifying the start 
and end frames, and the intervals of frames. 

1 With FCheck closed, open a command prompt window.

2 Determine what the start frame, end frame, and interval you want to 
open the animation with. 

3 Find out the format of the animation’s filename. 

See ”Convention for opening files” on page 67 to understand how 
FCheck specifies padded numbers for opening files. 

4 Type the following:

fcheck -n <start> <end> <interval> <filename> 

<start> is the number of the first frame to load.

<end> is the number of the last frame to load.

<interval> is the interval step to load by.

<filename> is sequence filename. The filename must follow 
guidelines set in ”Convention for opening files” on page 67. 

, <comma> backward play

<space> pause playback 

Ctrl + left arrow return to the first frame 

+ and - speed up and slow down the playback of the 
sequence. 

Tip: You can drag the mouse left and right using the left mouse 
button in the Playback window to scrub through a 
sequence. 

For more information on mouse controls, see”FCheck 
Mouse controls” on page 90. 
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5 Press Enter. 

A FCheck Playback window displays the animation according to the 
specifications entered. 

Creating a sequence of unrelated images.

Using the -S option, you can display a list of unrelated images. 

1 With FCheck closed, open a command prompt window.

2 Determine the images you want to make into a sequence. 

3 Type:

fcheck -S <filename1> <filename2> <filename3>... 

where <filename1,2,3,...> represents the images you want to 
display as a sequence in FCheck. The first image in the list is the start 
frame, and the last image is the end frame. 

A FCheck Playback window will appear displaying the sequence. 

Adjust color values

Adjusting luminance

Luminance is the intensity of glowing or reflective light on a given 
image. The range of luminance settings in FCheck is between -100 and 
+100. 

Use the following keys to increase and decrease the luminance:

 =  Increasing luminance causes images to glow 
brighter. 

 -  Decreasing luminance causes images to dim.

(Mac OS X) You can also use the Info window to adjust the values. 

Adjusting saturation

Saturation is the amount of color vibrance in the image. The range of 
saturation settings in FCheck is between -100 and +100. 

Use the following keys to increase and decrease saturation:

Tip: The luminance, saturation, gamma, offset, animation speed 
control, bump gain, and bump color keyboard keys can be 
used with Shift, Alt and Ctrl keys. Hold down Shift, Alt or 
Ctrl keys while pressing the function key to increase the 
variations. Shift = 10%, Alt = 50%, and Ctrl resets the value. 

For more information and a full description of these keys, 
see ”Image adjustment keys” on page 82.
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‘(apostrophe) Increasing saturation increases the shine of the color 
tones in the image by taking existing colors in the 
image and adding more of the same colors. The 
more saturated the image, the more it looks like a 
child’s color painting. 

;(semicolon) Decreasing saturation increases the amount of black 
and white tones in the image. When an image is 
totally desaturated (-100), the image appears in 
black and white. 

(Mac OS X) You can also use the Info window to adjust the values. 

Adjusting gamma

Gamma is the overall brightness of an image. Changes to gamma not 
only adjusts the brightness, but also adjusts ratios of colors in the 
image. The range of gamma settings in FCheck is between -100 and 
+100. Use the following keys to increase and decrease gamma.

 ]  Increasing gamma will make the image brighter and 
paler. A “bleached out” effect occurs. 

 [  Decreasing gamma darkens the color tones in an 
image. Overall brightness is also decreased.

(Mac OS X) You can also use the Info window to adjust the values. 

A specific gamma value can also be entered by typing fcheck -G 
<gamma> into the command prompt and opening an image/sequence. 
<gamma> represents the gamma value wanted. 

Save images or sequences 

For information on supported file formats, see ”Supported save formats” 
on page 87.

Note: Images have an initial gamma value, but sometimes it is not 
the one you want. Programs such as Matador change the 
gamma value in RLA files because Matador writes a 2.2 
gamma while storing the image in gamma 1.0 and the 
image looks washed out when you display it using FCheck 
or a compositing software. 

By supplying the correct gamma value using the -G option 
on the command line, you can display the image as 
intended. This is one of the most useful command line 
options in FCheck acting as a gamma repair tool.
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To save an image on Windows or Mac OS X 

1 Select File > Save Image to save the current frame as an image.

2 In the file browser, enter a name and extension for your file, select a 
format and destination for the file, and click Save.

Your file is saved to the specified folder.

To save an image using hotkeys (Linux/IRIX)

Do one of the following:

• If you do not want to overwrite the current filename, press w to save 
the file as fcheck.out.1. The file will be numbered 1 if it is not 
already numbered. If is already numbered, it will number the file with 
the same frame number as before. 

• If you want to overwrite the current filename, first press F11 to turn 
on file overwriting, then press w to save the file. The old file is 
replaced with the newly saved file. 

Your file is saved in the same directory where the file was opened.

To save a sequence on Windows

1 Select File > Save Animation to save the animation as a sequence of 
images.

2 In the file browser, enter a name and extension for your file, select a 
format and destination for the file, and click Save.

For information on frame numbering and padding numbers, see 
”Frame numbering and padded numbers” on page 67.

Your file is saved to the specified folder.

To save a sequence on Mac OS X 

1 Select File > Save As Sequence to save the animation as a sequence of 
images.

2 In the file browser, enter a name and extension for your file, select a 
format and destination for the file, and click Save.

For information on frame numbering and padding numbers, see 
”Frame numbering and padded numbers” on page 67.

Your file is saved to the specified folder.

To save a sequence using hotkeys (Linux/IRIX)

Do one of the following:
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• If you do not want to overwrite the current sequence filenames, press 
Shift + w to save the files as fcheck.out.1,2,.... The files will be 
numbered according to it’s original frame number in the sequence.    

• If you want to overwrite the current sequence filenames, first press 
F11 to turn on file overwriting, then press Shift + w to save the files. 
The old files are replaced with the newly saved files. 

Your files are saved in the same directory where the sequence was 
opened.

To save as QuickTime movie on Mac OS X 

1 Select File > Save As Movie to save the animation as a QuickTime 
movie.

2 In the file browser, enter a name and extension for your file, select a 
format and destination for the file, and click Save.

Your file is saved to the specified folder.

For information on supported file formats, see ”Supported file formats” 
on page 86

Use FCheck with sound

FCheck can import sound files, associate them with an image sequence, 
and play them back in sync with your image sequence. To import a sound 
file, select File > Import Sound. To turn sound on or off, select File > 
Toggle Sound.

Use FCheck with Maya

You can now launch FCheck from within Maya by selecting File > View 
Image or File > View Sequence.

Maya uses FCheck as an image previewer to display intermediate results 
of a rendering. FCheck can be opened within Maya when using the 
following tools. 

Playblast

Uses FCheck to externally preview the current animation. 

See “Playblast” in the Animation guide on how to use FCheck with 
playblast.

Hardware Render Buffer

Uses FCheck to externally display an animation rendering rendered 
using your computer’s display graphics card. 
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See “Use the hardware render buffer” in the Rendering guide on how 
to use FCheck with hardware render buffer. 

Batch Render

The “Show Batch Render” function uses FCheck to preview the latest 
rendered image when batch rendering. 

See “Show Batch Render” in the Rendering guide on how to open 
FCheck when batch rendering. 

Reference Windows and Editors

FCheck

FCheck options list

For information on how to use FCheck options, see ”FCheck options” on 
page 65.

Note: The FCheck Info window on Mac OS X contains options you 
can set. The following options are not available: offset, 
bump, color, negate.

Windows/
Mac OS X

Linux/IRIX Description

-a -a Displays all blocks, giving the 
coordinates and weight of each tile (to 
be used with the -c option). 

Note: Blocks and tiles are image 
spaces Maya uses in its process of 
rendering an image.

-B Turns off the border around an image.

-C <x> <y> 
<width> 
<height>

Crops an image. <x> and <y> 
represents the bottom left starting 
plane points. Use <width> and 
<height> to size the image. 
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-c -c Checks completeness of the .iff tags 
present in a sequence. If the sequence 
is incomplete or corrupted, FCheck 
prints out an error. This is done 
without opening the sequence. 

-D Sets up your machine for stereo mode. 
However, if stereo mode is not 
activated, you need to quit FCheck so 
that the video mode is restored. 

-d -d Runs in demo mode using a full 
screen window.

-F -F Displays images in full resolution 
preventing automatic rescaling of 
large images.

-f -f Finds the first available image in an 
animation.

-G <gamma> -G <gamma> Sets the gamma value in RLA images. 
Use <gamma> to specify value.

-g -g Initial gamma correction, which you 
can change at any time.

-h -h Lists FCheck feature commands 
(Help).

-K -K Does inverse Kodak Cineon color 
correction (log to linear).

-k <mem> -k <mem> Stores or keeps images in memory, 
using the amount of memory defined 
in <mem> as a percentage of available 
memory. A value of 1 means that 
100% of memory is allocated. 

-l <level> -l <level> The level of analysis for complex IFF 
(Image File Format) style files.

Windows/
Mac OS X

Linux/IRIX Description
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-m <mag> -m <mag> Magnifies an image. <mag> is an 
integer specifying the factor of 
magnification.

-n <start> 
<interval>

<end> 
<filename>

-n <start> 
<interval>

<end> 
<filename>

Opens animations, indicating the start, 
end and step of the file (whole 
numbers). If you give a name ending 
with a period, FCheck automatically 
finds the start, end, and step of the 
corresponding animation. 

See ”Opening an animation using the -
n option” on page 72 for more details.

-p -p Pads frame numbers with zeros, 
needed for some image formats.

-r <rate> -r <rate> The rate at which animations are 
displayed. The default is ntsc, but you 
can also specify pal, film, or an integer 
number of frames per second (for 
example, 15).

-R <x> <y> Changes the resolution of an image by 
reducing image size. <x> and <y> 
represent the new width and height 
values respectively. 

-s <shrink> -s <shrink> Reduces an image. <shrink> is an 
integer specifying the factor of 
reduction.

-S -S Displays a sequence of images that are 
not arranged in any particular order, 
creating a loop of images, animations 
and sounds. 

-T <timer> -T <timer> Sets the number of seconds each frame 
is displayed. This option is used in 
combination with the -S option.

-v -v Verbose mode allows the maximum 
information output.

Windows/
Mac OS X

Linux/IRIX Description
Rendering Utilities

79



3 | FCheck
Reference > Display keys
On Windows, you can access keyboard short cuts by selecting Help > 
Keyboard from the FCheck window.

Display keys

When you have an image displayed using FCheck, you can use the 
following keys or the FCheck info window to control the display.

-w -w Waits until the image has finished 
rendering. The image is displayed 
only after the rendering is completed. 

-z -z Prevents Z-depth information from 
being loaded for images. This is useful 
when you do not have much memory.

-Z -Z Loads Z-depth information for images 
in animation mode.

Windows/
Linux/IRIX

Mac OS 
X

Action

a Displays the alpha bitplane channel in 
an image.

b b Displays the blue bitplane channel in 
an image.

c c
Displays an image by combining the 
color values contained in the three 
RGB planes. 

f
Switches between single and double 
buffer mode. Default mode depends 
on machine’s graphics card.

g g Displays the green bitplane channel in 
an image.

k Turns on and off Kodak Cineon 
correction.

Windows/
Mac OS X

Linux/IRIX Description
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m Displays the mask in an image.

p Prints out the current luminance, 
gamma, and saturation values.

p Displays the alpha bitplane channel.

r r Displays the red bitplane channel in an 
image.

x x Displays the negative.

Shift + x Reverses the mask displayed from 
using “x”.

z Displays the Z-depth information in 
gray levels.

Shift + z Displays the logarithm of the Z-depth 
values.

F5 Toggles on and off a cross-hair cursor 
and tracking while in tracking mode. 

F6
Displays all tracking points made in 
the same window FCheck started 
from.

Shift + F6 Writes a composer curve.

F8 Turns luminance curve on and off. 

F12 Displays the borders of image tiles. 

Use the numeric pad keys for the following 

0 0 Zooms in.

. (numpad 
period)

. (numpad 
period)

Zooms out.

1 to 9 1 to 9

Press the number between 1 and 9 to 
scroll over the current image. To scroll 
faster, press Shift and Alt in 
combination with the number.

Windows/
Linux/IRIX

Mac OS 
X

Action
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Image adjustment keys

Use the following keys to change the luminance, gamma, saturation or 
offset in images as well as change channel and manipulate colors. 

Please note that an image must be written to disk to retain image 
modifications and adjustments executed in FCheck. See ”Save images or 
sequences” on page 74 for more details.

Windows/
Linux/IRIX

Mac OS 
X

Action

` Resets all FCheck info window options.

d d
Resets the image to the state it was in 
before you made changes to the 
luminance, gamma and saturation.

i
Displays the inverted bump; Similar to 
pressing n except that shows a negative 
gain. 

l

Controls the luminance in an image, 
based on the weighted RGB. To toggle 
between line drawings and points, 
press L while holding down Shift.

n Displays the normal bump. Increase 
depth by pressing and  keys.

u Updates or reloads the image.

w Saves current image.

Shift + w Saves entire animation.

= } Increase the luminance by 1%.

Shift + = Increases the luminance by 10%.

Alt + = Increases the luminance by 50%.

- 

(keyboard, not 
numeric pad)

{
Decreases the luminance by 1%.
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Shift + -

(keyboard, not 
numeric pad)

Decreases the luminance by 10%.

Alt  + -
(keyboard, not 
numeric pad)

Decreases the luminance by 50%.

Ctrl + =/- Pressing either Ctrl - or Ctrl + restores 
image to original luminance value. 

] ] Increases the gamma by 1%.

Shift + ] Increases the gamma by 10%.

Alt + ] Increases the gamma by 50%.

[ [ Decreases the gamma by 1%.

Shift + [ Decreases the gamma by 10%.

Alt + [ Decreases the gamma by 50%.

Ctrl + ]/[ Pressing either Ctrl ] or Ctrl [ restores 
image to original gamma value. 

/ Increases the offset by 1%.

Shift + / Increases the offset by 10%.

Alt + / Increases the offset by 50%.

\ Decreases the offset by 1%.

Shift + \ Decreases the offset by 10%.

Alt + \ Decreases the offset by 50%.

Ctrl + \ or / Restores image to original offset value. 

‘ ‘ Increases the saturation by 1%.

Shift + ‘ Increases the saturation by 10%.

Alt + ‘ Increases the saturation by 50%.

Windows/
Linux/IRIX

Mac OS 
X

Action
Rendering Utilities

83



3 | FCheck
Reference > Image adjustment keys
; ; Decreases the saturation by 1%.

Shift + ; Decreases the saturation by 10%.

Alt + ; Decreases the saturation by 50%.

Ctrl + ‘/; Pressing either Ctrl ‘ or Ctrl ; restores 
image to original saturation value. 

F1 Switches to red bitplane channel 
control.

F2 Switches to green bitplane channel 
control.

F3 Switches to blue bitplane channel 
control.

F4
Switches to all colors (RGB) bitplane 
channel control. This is the default 
channel control in FCheck.

Shift + F1 Switches to cyan bitplane channel 
control.

Shift + F2 Switches to magenta bitplane channel 
control.

Shift + F3 Switches to yellow bitplane channel 
control. 

F11 Allows images to be overwritten. 

Use the numeric pad keys for the following

/ / Decreases the percentage of color 
added to the bump image.

* * Increases the percentage of color added 
to the bump image.

Ctrl +/ Ctrl +/ Undoes any color changes made by 
resetting value to zero.

Windows/
Linux/IRIX

Mac OS 
X

Action
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Animation playback control keys

Use the following keys to control animation playback in FCheck. 

Ctrl + * Ctrl + * Undoes any color changes made by 
resetting value to 100%.

Windows/
Linux/IRIX

Mac OS 
X

Action

comma comma Plays animation backwards 
continuously. 

period  period Plays animation forwards continuously.

space space Pauses the animation. Press again to 
resume.

Shift + , Sets current frame the starting frame in 
the animation.

Shift + . Sets current frame the ending frame in 
the animation.

Alt + , Plays animation backwards once.

Alt + . Plays animation forward once.

- - Slows down the playback speed of 
animation.

+ + Speeds up the playback speed of 
animation

right arrow right 
arrow

Proceeds to the next frame after 
animation is paused.

left arrow left 
arrow

Recedes to the previous frame after 
animation is paused.

Ctrl + right 
arrow

Proceeds to the last frame in the 
animation.

Windows/
Linux/IRIX

Mac OS 
X

Action
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Supported file formats

The file format native to FCheck is Maya Image File Format (IFF). When a 
file is not in IFF format, FCheck uses an external converter called toimg to 
convert the images or animation. The conversion allows FCheck to display 
the image or animation in its playback window. The following is a list of 
FCheck supported file formats.

Ctrl + left arrow Returns to the first frame in the 
animation.

s Cycles through animation forwards and 
backwards continuously.  (Swinging)

t Plays animation in real time, skipping 
images if necessary. 

Format Extension

Abekas NTSC or PAL .yuv

Alias .als

Explore

GIF .gif

JPEG .jpg

Kodak Cineon .cin

Lucas Film .lff

Pixibox PXB and SCN .pxb or .scn

PPM raw/ascii .ppm

Prisms .pri

Quantel .qtl

SGI .rgb, .sgi or .bw

Softimage .pic

Windows/
Linux/IRIX

Mac OS 
X

Action
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Supported save formats

FCheck is also able to save in multiple file formats. In addition to the 
formats available, FCheck is able to save an image or sequence in 
QuickTime .mov file format on Mac OS X. The following is a list of 
supported save formats in FCheck.

Targa RGB/BW .tga

TIFF 6.0 .tif or .tiff

Vista .vst

Wavefront RLA .rla

Format Extension

Maya IFF .iff

Silicon Graphics .rgb, .sgi or .bw

Adobe Photoshop .ps

Targa .tga

TIFF .tif

GIF (Windows/Linux/IRIX) .gif

JPEG .jpg

JPEG-2000  (Mac OS X) .jp2

PNG .png

Apple PICT .pict

Windows 16- or 32-bit bitmap .bmp

MacPaint .pntg

QuickTime Image .qtif

Format Extension
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FCheck File menu

About fcheck (Mac OS X) 

Opens a window with a description of FCheck. 

Open Image (Windows/Mac OS X)

Loads image into FCheck playback window. 

Open Animation (Windows) 

Open Sequence (Mac OS X) 

Loads animation/ sequence into FCheck playback window. 

Revert (Windows/Mac OS X) 

Reloads the image or animation to the status of the most recent save 
on disk. 

Import Sound

Imports sound into the FCheck viewer so you can play back sound 
and animation.

Toggle Sound

Toggles sound on and off.

Save Image (Windows/Mac OS X) 

Enter a filename to save the image. By default, the file is saved as 
.iff.

Save Animation (Windows) 

Save As Sequence (Mac OS X) 

Enter a filename to save the animation/ sequence. By default the file is 
saved as .iff.

Save As Movie (Mac OS X) 

Select a location and enter filename to save file as a QuickTime .mov.

Exit (Windows) and Quit (Mac OS X)

Exits the program. 

Fcheck View menu (Windows)

Select to view specific channels from the View menu. By default, the 
display is set to All Channels. 

The following is a list of channels available in the menu. 
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Red Channel

Displays the red channel.

Blue Channel

Displays the blue channel.

Green Channel

Displays the green channel.

Alpha Channel

Displays the alpha channel.

All Channel

Displays RGB channels.

Luminance

Displays the image in black and white.

Control Bar

Toggles the control bar on and off.

Full Screen

Displays the image or animation full screen.

Full Resolution

Displays the image or animation at full resolution.

FCheck Help menu (Windows)

Select an item to open a window which displays a number of help items, 
including keyboard controls, command line options, and so on.

For information on commands, see ”FCheck” on page 77.

The following is a list of choices available in the menu:

• Manipulations

• Opening/Saving Images

• Animation Controls

• Command Line

• Mouse Controls

• Keyboard

• About
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FCheck Mouse controls

The following table describes the mouse controls used in FCheck:

FCheck Control Bar 

Use the Control Bar buttons for the following:

Mouse button Description

Hold the left mouse button to scrub through 
sequence of frames. Drag the mouse while holding 
the left mouse button to the left to reverse and to the 
right to advance.

(Windows, Linux, and IRIX) Press the middle mouse 
button over the playback window to display 
coordinates of the pixels under the cursor. The 
coordinates appear in the command-line window.

(Windows, Linux, and IRIX) Pressing the right 
mouse button actives the dot drawing tool in image 
plane. Drag the mouse while holding the right 
mouse button to create a flowing line.

(Mac OS X) Pans the image in the playback window.

Go to first frame.

Go back one frame.

Play backwards. (Changes to 
Stop when playing backwards.)

Play forward. (Changes to Stop 
when playing forward.)

Go forward one frame.

Go to last frame.
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You can toggle the Control Bar on and off using the View > Control Bar 
menu item.

Shows frames per second.

Show alpha channel.

Show all channels.

Show Z buffer.
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About Command line renderer

Command line renderer

The command line renderer can be used to render an image or series of 
images using any of the integrated Maya renderers. The command line 
renderer works as a background task and has no graphical user interface.  
It is an optimized rendering utility, and it therefore uses less resources 
than Maya.

The command line renderer can be launched on a workstation while a 
standard Maya session is running, however, be aware that both 
applications will require seperate resources.  Make sure that suffecient 
memory and disk space are available for both applications to run 
properly.

You can specify many aspects of a render from the command line, 
including which integrated renderer to use, the image size and file name 
to use.

The command line renderer provides a unified approach to all the 
integrated Maya renderers. Some flags are common to all renderers, and 
some flags are unique to a renderer. 

Related topics

”Render from the command line” on page 93.

”Common flags for the command line renderer” on page 95.

”Renderer-specific flags for the command line renderer” on page 96.

How do I? Render from the command line

Path to Render

On Windows and IRIX, the path to the Render command is set for you 
during installation (on Windows, by adding to the system PATH 
environment variable; on IRIX, by adding symlinks to /usr/sbin). On 
Mac OS X and Linux, you must either include the path as part of the 
command, or set your system path to include the path to Render. See your 
platform documentation for how to accomplish this.

On Mac OS X, the Render command is located at:
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/Applications/Alias/maya6.5/Maya.app/Contents/bin/

On Linux, the Render command is located at:

/usr/aw/maya6.5/bin

To render from the command line

Do one of the following:

• At the command prompt, shell, or Terminal window, type:

Render -r <renderer name> <options> <filename>

where <renderer name> is the name of the renderer:

• mr = mental ray

• sw = software renderer

• hw = hardware renderer

• vr = vector renderer

and where <filename> is (generally) a Maya ASCII or Maya Binary 
file, and <options> is one or more of the options or flags.

This renders the image or animation using the renderer you specify in 
the command line.

• At the command prompt, type:

Render <options> <filename>

<filename> is (generally) a Maya ASCII or Maya Binary file, and 
<options> is one or more of the options or flags.

This renders the image or animation using the renderer defined in the 
file.

For descriptions of the common command line renderer flags, see 
”Common flags for the command line renderer” on page 95.

For descriptions of the renderer-specific command line renderer flags, see 
”Renderer-specific flags for the command line renderer” on page 96.

Stop a command line render

You may occasionally need to stop a command line render before it has 
finished. 

To stop a command line render on Windows

1 Open the Task Manager by doing one of the following:

• Press Ctrl-Alt-Delete and click the Task Manager button.

• Right-click an empty space on the taskbar and select Task 
Manager from the menu that appears.
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2 Click the Processes tab.

3 Select the Render.exe process.

4 Click the End Process button.

To stop a command line render on Mac OS X

You can quit a command line render from the dock. Right-click the Maya 
Renderer application in the dock and select Quit from the pop-up menu.

To stop a command line render on IRIX or Linux

1 From a shell, list the top processes by entering:

top

2 Note the render process ID.

3 To stop the process, enter: 

kill -2 <process ID>

Reference Common flags for the command line renderer

The following table contains the common flags shared by all the renderers. 
To view these, type the following in a shell or Terminal (Mac OS X) 
window:

Render -h

Flag name Definition

-test Print MEL commands but do not execute 
them

-verb Print MEL commands before they are 
executed

-keepMel Keep the temporary MEL file

-listRenderers Lists all available renderers

-renderer <string> or 
-r <string>

Use this specific renderer: sw, hw, mr, vr

-proj <string> Use this Maya project to load the file
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Renderer-specific flags for the command line 
renderer

For flags specific to one of the integrated Maya renderers, type the 
following in a shell or Terminal (Mac OS X) window:

Render -r <renderer name> -help

where <renderer name> is the name of the renderer (sw, mr, hw, vr).

For example:

-preRender <string> Executes this MEL script after loading 
the file

-postRender <string> Executes this MEL script before quitting

-sel Selects individual objects, groups or 
sets.

-l Selects display layers or render layers.

-log Specifies a render log file and location. 
The log file contains the standard 
output and standard error information.

-lic Checks out the best available license for 
mental ray for Maya. Two options are 
available for this flag, mu and mc. 

The mu option checks for a mental ray 
for Maya Unlimited license. If the 
license is available, it is used, and the 
maximum number of satellites is set to 
8. If the license is not available, a mental 
ray for Maya Complete license is used, 
and the maximum number of satellites 
is set to 2.

The mc option checks out a mental ray 
for Maya Complete license. The 
maximum number of satellites is set to 
2.

This flag is for use with mental ray's 
Satellite rendering.

Flag name Definition
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Render -r mr -help

which lists the flags for the mental ray for Maya renderer.

The following are tips for command line rendering flags:

• Remember to place a space between option flags and their arguments. 

• Any boolean flag will take on the following as true: on, yes, true, or 1; 
likewise, the following as false: off, no, false, or 0. For example:

-x 512 -y 512 -cam persp -im test -of jpg -mb on -sa 
180 file

Related topics

”Maya Software renderer command line renderer flags” on page 97.

”mental ray for Maya renderer command line renderer flags” on 
page 102.

”Hardware renderer command line renderer flags” on page 104.

”Vector renderer command line renderer flags” on page 105.

Maya Software renderer command line renderer 
flags

Below are all the flags and their descriptions unique to command line 
rendering with the Maya Software renderer. You can also type Render -r 
sw -help in a shell or Terminal (Mac OS X) window to see this list.

See also ”Common flags for the command line renderer” on page 95.

Flag Definition

-rd <path> Directory in which to store image files.

-im <filename> Image file output name.

-fnc <int> File Name Convention, such as name, name.ext
For details, see the Common tab of the Render 
Global Settings window in the Rendering book.

-of <format> Output image file format. For supported file 
formats, see File Formats in the Rendering book.

-s <float> Start frame for an animation sequence.

-e <float> End frame for an animation sequence.

-b <float> By frame (or step) for an animation sequence.
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Antialiasing flags

-pad <int> Number of digits in the output image frame file 
name extension.

-rfs <int> Renumber Frame Start - number for the first 
image when rendering.

-rfb <int> Renumber Frame By - step used for 
renumbering frames.

-cam <name> Specify which camera to  be used.

-rgb <boolean> Turn RGB output on or off.

-alpha <boolean> Turn Alpha output on or off.

-depth <boolean> Turn Depth output on or off.

-iip Ignore Image Planes turns off all image planes 
before rendering.

-x <int> Set X resolution of the final image.

-y <int> Set Y resolution of the final image.

-ard <float> Device aspect ratio for the rendered image.

-pre <string> MEL code executed before each frame.

-post <string> MEL code executed after each frame.

Flag Definition

-eaa <int> Anti-aliasing quality of EAS (Abuffer). One of: 
highest (0),  high (1), medium (2), or low (3).

-ss <int> Global number of shading samples per surface 
in a pixel.

-mss <int> Maximum number of adaptive shading samples 
per surface in a pixel.

-mvs <int> Number of motion blur visibility samples.

Flag Definition
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Raytracing quality flags

-mvm <int> Maximum number of motion blur visibility 
samples.

-pss <int> Number of particle visibility samples.

-vs <int> Global number of volume shading samples.

-ufil <boolean> If true, use the multipixel filtering; otherwise, 
use single pixel filtering.

-pft <int> When useFilter is true, identifies one of the 
following filters: box (0),  triangle (2), gaussian 
(4), quadratic (5).

-pfx <float> When useFilter is true, defines the X size of the 
filter.

-pfy <float> When useFilter is true, defines the Y size of the 
filter.

-rct <float> Red channel contrast threshold.

-gct <float> Green channel contrast threshold.

-bct <float> Blue channel contrast threshold.

-cct <float> Pixel coverage contrast threshold (default is 1.0/
8.0).

Flag Definition

-ert <boolean> Enable ray tracing.

-rfl <int> Maximum raytracing reflection level.

-rfr <int> Maximum raytracing refraction level.

-sl <int> Maximum raytracing shadow ray depth.

Flag Definition
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Field options flags

Motion blur flags

Render options flags

Flag Definition

-field <boolean> Enable field rendering. When enabled, images 
are interlaced.

-pal <boolean> When field rendering is enabled, render even 
field first (PAL).

-ntsc <boolean> When field rendering is enabled, render odd 
field first (NTSC).

Flag Definition

-mb <boolean> Motion blur on/off.

-mbf <float> Motion blur by frame.

-sa <float> Shutter angle for motion blur (1-360).

-mb2d <boolean> Motion blur 2D on/off.

-bll <float> 2D motion blur length.

-bls <float> 2D motion blur blur sharpness.

-smv <int> 2D motion blur smooth value.

-smc <boolean> 2D motion blur smooth color on/off.

-kmv <boolean> Keep motion vector for 2D motion blur on/off.

Flag Definition

-ifg <boolean> If false, use the film gate for rendering.

-edm <boolean> Enable depth map usage.

-g <float> Gamma value.
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Memory and performance flags

Render layers and passes flags
.

Other flags

-premul <boolean> Premultiply color by the alpha value.

-premulthr <float> When premultiply is, defines the threshold used 
to determine whether to premultiply or not.

Flag Definition

-uf <boolean> Use the tessellation file cache.

-oi <boolean> Dynamically detects similarly tessellated 
surfaces.

-rut <boolean> Reuse render geometry to generate depth maps.

-udb <boolean> Use the displacement bounding box scale to 
optimize displacement map performance.

-mm <int> Renderer maximum memory use (in 
megabytes).

Flag Definition

-rl <boolean:name> Render each layer separately.

-rp <boolean:name Render passes separately.

-rs <boolean> Render layer output placed in subdirectories.

Flag Definition

-rep Do not replace the rendered image if it already 
exists.

Flag Definition
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mental ray for Maya renderer command line renderer 
flags

Below are all the flags and their descriptions unique to command line 
rendering with the mental ray for Maya renderer. You can also type 
Render -r mr -help in a shell or Terminal (Mac OS X) window to see 
this list.

See also ”Common flags for the command line renderer” on page 95.

-reg <int int int 
int>

Set su- region pixel boundary of the final image 
(left, right, bottom, top).

-n <int> Number of processors to use. 0 indicates use all 
available.

-mf <boolean> If true, append image file format to image name.

-sp <boolean> Generate shadow depth maps only.

-amt Abort renderer when encountered missing 
texture.

-ipr <boolean> Create an IPR file.

-keepPreImage Keep the renderings prior to post-process.

Flag Description

-rd <path> Directory in which to store image files.

-im <filename> Image file output name.

-fnc <int> File Name Convention: 2 (name.ext - single 
frame), 3 (name.#.ext), 4 (name.ext.#).

-of <format> Output image file format. For supported file 
formats, see File Formats in the Rendering book.

-s <float> Start frame for an animation sequence.

-e <float> End frame for an animation sequence.

-b <float> By frame (or step) for an animation sequence.

Flag Definition
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-pad <int> Number of digits in the output image frame file 
name extension.

-rfs <int> Renumber Frame Start - number for the first 
image when rendering.

-brf <int> Renumber Frame By - step used for 
renumbering frames.

-pre <string> MEL code executed before each frame.

-post <string> MEL code executed after each frame.

-v <int> Set the verbosity level: 0 for no messages, 6 for 
detailed messages.

-log <boolean> If true, write a log to mentalray.log in the current 
directory.

-cam <name> Specify which camera to  be rendered.

-rgb <boolean> Turn RGB output on or off.

-alpha <boolean> Turn Alpha output on or off.

-depth <boolean> Turn Depth output on or off.

-iip Ignore Image Planes turns off all image planes 
before rendering.

-x <int> Set X resolution of the final image.

-y <int> Set Y resolution of the final image.

-ard <float> Device aspect ratio for the rendered image.

-rt <int> Specify the number of rendering threads. 1 to 4.

-rnm <boolean> Network rendering option. If true, mental ray 
renders almost everything on slave machines, 
thus reducing the workload on the master 
machine.

Flag Description
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Hardware renderer command line renderer flags

Below are all the flags and their descriptions unique to command line 
rendering with the Hardware renderer. You can also type Render -r hw 
-help in a shell or Terminal (Mac OS X) window to see this list.

See also ”Common flags for the command line renderer” on page 95.

Flag Description

-rd <path> Directory in which to store image files.

-im <filename> Image file output name.

-s <float> Start frame for an animation sequence.

-e <float> End frame for an animation sequence.

-b <float> By frame (or step) for an animation sequence.

-rfs <int> Renumber Frame Start - number for the first 
image when rendering.

-rfb <int> Renumber Frame By or step used for 
renumbering frames.

-cam <name> Specify which camera to  be rendered.

-rgb <boolean> Turn RGB output on or off.

-alpha <boolean> Turn Alpha output on or off.

-depth <boolean> Turn Depth output on or off.

-x <int> Set X resolution of the final image.

-y <int> Set Y resolution of the final image.

-par <float> Pixel aspect ratio for the rendered image.

-pre <string> MEL code executed before each frame.

-post <string> MEL code executed after each frame.
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Quality flags

Render flags

Vector renderer command line renderer flags

Below are all the flags and their descriptions unique to command line 
rendering with the Vector renderer. You can also type Render -r vr -
help in a shell or Terminal (Mac OS X) window to see this list.

See also ”Common flags for the command line renderer” on page 95.

Flag Definition

-ehl <boolean> Enable high quality lighting.

-ams <boolean> Accelerated multi sampling.

-ns <int> Number of samples per pixel.

-tsc <boolean> Transparent shadow maps.

-ctr <int> Color texture resolution.

-btr <int> Bump texture resolution.

-tc <boolean> Enable texture compression.

Flag Definition

-rl <boolean> Enable render layers.

-c <boolean> Culling mode: 0 (per object), 1 (all double sided), 
2 (all single sided).

-sco <boolean> Enable small object culling.

-ct <float> Small object culling threshold.

-mb <boolean> Enable motion blur.

-mbf <float> Motion blur by frame.

-ne <int> Number of exposures.

-egm <boolean> Enable geometry mask.
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Flag Definition

-rd <path> Directory in which to store image files.

-im <filename> Image file output name.

-s <float> Start frame for an animation sequence.

-e <float> End frame for an animation sequence.

-b <float> By frame (or step) for an animation sequence.

-pad <int> Number of digits in the output image frame file 
name extension.

-rfs <int> Renumber Frame Start - number for the first 
image when renumering frames.

-rfb <int> Renumber Frame By (or step) used for 
renumbering frames.

-cam <name> Specify which camera to  be rendered.

-rgb <boolean> Turn RGB output on or off.

-alpha <boolean> Turn Alpha output on or off.

-depth <boolean> Turn Depth output on or off.

-x <int> Set X resolution of the final image.

-y <int> Set Y resolution of the final image.

-par <float> Pixel aspect ratio for the rendered image.

-pre <string> MEL code executed before each frame.

-post <string> MEL code executed after each frame.
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